• HDU 1009 FatMouse' Trade(贪心)


    FatMouse' Trade

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 20968    Accepted Submission(s): 6501


    Problem Description
    FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
    The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
     
    Input
    The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
     
    Output
    For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
     
    Sample Input
    5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
     
    Sample Output
    13.333 31.500
     
    Author
    CHEN, Yue
     
    Source
     
    Recommend
    JGShining
     
     
    很简单的贪心题,
    先按照价值/代价的比值来排序,肯定是先买比值大的。
    代码如下:
    #include<stdio.h>
    #include<stdlib.h>

    const int MAXN = 1010;
    struct node
    {
    double j,f;
    double r;
    }a[MAXN];
    int cmp(const void *a,const void *b)//从大到小排序
    {
    struct node *c=(node *)a;
    struct node *d=(node *)b;
    if(c->r > d->r) return -1;
    else return 1;
    }
    int main()
    {
    int N;
    double M;
    double ans;
    while(scanf("%lf%d",&M,&N))
    {
    if(M==-1&&N==-1) break;
    for(int i=0;i<N;i++)
    {
    scanf("%lf%lf",&a[i].j,&a[i].f);
    a[i].r=(double)a[i].j/a[i].f;
    }
    qsort(a,N,sizeof(a[0]),cmp);
    ans=0;
    for(int i=0;i<N;i++)
    {
    if(M>=a[i].f)
    {
    ans+=a[i].j;
    M-=a[i].f;
    }
    else
    {
    ans+=(a[i].j/a[i].f)*M;
    break;
    }
    }
    printf("%.3lf\n",ans);
    }
    return 0;
    }
     
    sort排序版本:
    #include<stdio.h>
    #include<stdlib.h>
    #include<algorithm>
    using namespace std;
    const int MAXN = 1010;
    struct node
    {
    double j,f;
    double r;
    }a[MAXN];
    /*
    int cmp(const void *a,const void *b)//从大到小排序
    {
    struct node *c=(node *)a;
    struct node *d=(node *)b;
    if(c->r > d->r) return -1;
    else return 1;
    }
    */
    bool cmp(node a,node b)
    {
    return a.r > b.r;
    }
    int main()
    {
    int N;
    double M;
    double ans;
    while(scanf("%lf%d",&M,&N))
    {
    if(M==-1&&N==-1) break;
    for(int i=0;i<N;i++)
    {
    scanf("%lf%lf",&a[i].j,&a[i].f);
    a[i].r=(double)a[i].j/a[i].f;
    }
    //qsort(a,N,sizeof(a[0]),cmp);
    sort(a,a+N,cmp);
    ans=0;
    for(int i=0;i<N;i++)
    {
    if(M>=a[i].f)
    {
    ans+=a[i].j;
    M-=a[i].f;
    }
    else
    {
    ans+=(a[i].j/a[i].f)*M;
    break;
    }
    }
    printf("%.3lf\n",ans);
    }
    return 0;
    }
  • 相关阅读:
    Java基础知识【上】(转载)
    Windows下Python中pip安装Pillow报错总结(转载)
    CentOS7下安装Python的pip
    CentOS7安装NodeJS6.9
    PostGIS(解压版)安装
    CentOS7中安装Python3.5
    CentOS7安装docker
    Centos7更改默认启动模式(转载)
    CentOS7 查看IP、Gateway、DNS、Hostname
    CentOS7系统安装及初始化
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2395223.html
Copyright © 2020-2023  润新知