• HDU 2131 Probability(水题) by kuangbin


    Probability

    Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 2313    Accepted Submission(s): 1146


    Problem Description
    Mickey is interested in probability recently. One day , he played a game which is about probability with mini.First mickey gives a letter and a word to mini.Then mini calculate the probability that the letter appears in the word.For example,give you the letter "a" and the word "apple". the probability of this case is 0.20000.
     
    Input
    The input contains several test cases. Each test case consists of a letter and a word.The length of the word is no longer than 200.
     
    Output
    For each test case, print the probability rounded to five digits after the decimal point.
     
    Sample Input
    a apple c Candy a banana
     
    Sample Output
    0.20000 0.20000 0.50000
     
    Author
    KiKi
     
    Source
     
    Recommend
    威士忌
     
     
    #include<stdio.h>
    #include<string.h>
    char str[210];
    int main()
    {
    char ch1,ch2;
    while(scanf("%c %s",&ch1,&str)!=EOF)
    {
    if(ch1>='a'&&ch1<='z')ch2=ch1-'a'+'A';
    else ch2=ch1-'A'+'a';
    int len=strlen(str);
    int tt=0;
    for(int i=0;i<len;i++)
    {
    if(str[i]==ch1||str[i]==ch2)tt++;
    }
    printf("%.5lf\n",(double)tt/len);
    getchar();
    }
    return 0;
    }
  • 相关阅读:
    数字和字母交替打印
    日期和字符串的转化
    redis简介
    管理MySQL的命令
    创建mysql数据表成功
    微信账号 echo_server 的实现
    html5 画个圈
    php练习1
    人生十大点
    养生“六伤”、“十二莫”、“十二少”
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2249142.html
Copyright © 2020-2023  润新知