Regular Polygon
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 682 Accepted Submission(s): 174
Problem Description
In a 2_D plane, there is a point strictly in a regular polygon with N sides. If you are given the distances between it and N vertexes of the regular polygon, can you calculate the length of reguler polygon's side? The distance is defined as dist(A, B) = sqrt( (Ax-Bx)*(Ax-Bx) + (Ay-By)*(Ay-By) ). And the distances are given counterclockwise.
Input
First a integer T (T≤ 50), indicates the number of test cases. Every test case begins with a integer N (3 ≤ N ≤ 100), which is the number of regular polygon's sides. In the second line are N float numbers, indicate the distance between the point and N vertexes of the regular polygon. All the distances are between (0, 10000), not inclusive.
Output
For the ith case, output one line “Case k: ” at first. Then for every test case, if there is such a regular polygon exist, output the side's length rounded to three digits after the decimal point, otherwise output “impossible”.
Sample Input
2
3
3.0 4.0 5.0
3
1.0 2.0 3.0
Sample Output
Case 1: 6.766
Case 2: impossible
Source
Recommend
lcy
二分求解:
#include<stdio.h>
#include<iostream>
#include<math.h>
using namespace std;
const double eps=1e-10;
double m[110][2];
int n;
const double PI=acos(-1.0);
int jug(double mid)
{
double sum=0.0;
int i;
double temp;
for(i=0;i<n;i++)
{
if(mid>(m[i][0]+m[i][1])-eps) return 1;
if(mid<fabs(m[i][0]-m[i][1])+eps) return -1;
temp=(m[i][0]*m[i][0]+m[i][1]*m[i][1]-mid*mid)/(2.0*m[i][0]*m[i][1]);
sum+=acos(temp);
}
if(sum>PI*2.0+eps) return 1;
if(sum<PI*2.0-eps) return -1;
else return 0;
}
int main()
{
int i,T;
int iCase=0;
scanf("%d",&T);
double l,r,temp;
while(T--)
{
iCase++;
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%lf",&m[i][1]);
m[i+1][0]=m[i][1];
}
m[0][0]=m[n][0];
bool flag=false;
double mid;
int temp1;
l=0;
r=20000;
while((r-l)>eps)
{
mid=(r+l)/2;
temp1=jug(mid);
if(temp1==0)
{
flag=true;
break;
}
if(temp1<0) l=mid;
else r=mid;
}
if(!flag) printf("Case %d: impossible\n",iCase);
else printf("Case %d: %.3lf\n",iCase,mid);
}
return 0;
}