• ACM HDU1001Sum Problem


    Sum Problem

    Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 113869    Accepted Submission(s): 26069


    Problem Description
    Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

    In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
     

    Input
    The input will consist of a series of integers n, one integer per line.
     

    Output
    For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
     

    Sample Input
    1 100
     

    Sample Output
    1 5050
     

    Author
    DOOM III
     
     
    #include<stdio.h>
    int main()
    {
    int n;
    int sum;
    while(scanf("%d",&n)!=EOF)
    {
    if(n%2==0) sum=n/2*(n+1);
    else sum=(n+1)/2*n;//防溢出
    printf("%d\n\n",sum);
    }
    return 0;
    }

  • 相关阅读:
    七牛云的 python sdk 是如何 批量删除资源的
    mysql 主从复制
    django3上线部署踩的坑
    基于linux在线预览
    数据库2
    数据库3
    安装 webstorm--->vue
    Django基础1
    pymysql基础
    前段之jQuery
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2117192.html
Copyright © 2020-2023  润新知