• hdu 1025


    Problem Description
    JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

    Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

    With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

    Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

    The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

    But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

    For example, the roads in Figure I are forbidden.



    In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
     
    Input
    Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
     
    Output
    For each test case, output the result in the form of sample. 
    You should tell JGShining what's the maximal number of road(s) can be built. 
     
    Sample Input
    2 1 2 2 1 3 1 2 2 3 3 1
     
    Sample Output
    Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
    Hint
    Huge input, scanf is recommended.
     
    Author
    JGShining(极光炫影)
     
    Recommend
    We have carefully selected several similar problems for you:  1081 1074 1078 1080 1059 
     
    解题思路:
    求最长子序列长度,需要注意的是当长度为1时,road后面没有s!
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<cmath>
    #include<stack>
    using namespace std;
    const int MAX=1e5+10;
    #define INF 0x7fffffff
    #define ll long long
    #define FOR(i,n) for(i=1;i<=n;i++)
    #define mst(a) memset(a,0,sizeof(a))
    //struct num{int a,b,c;}a[1005];
    int dp[500009],road[500009];
    int main()
    {
        int m,i,a,b;
        int c = 1;
        while(scanf("%d",&m)!=EOF){
            fill(dp,dp+m,INF);
           for(i=0;i<m;i++){
                scanf("%d%d",&a,&b);
                road[a] = b;
            }
            for(i=1;i<=m;i++){
                *lower_bound(dp,dp+m,road[i])=road[i];
            }
            int len = lower_bound(dp,dp+m,INF)-dp;
            if(len==1)
            {
                cout<<"Case "<<c++<<":"<<endl;
                cout<<"My king, at most 1 road can be built."<<endl;
            }
            else
            {
                cout<<"Case "<<c++<<":"<<endl;
                cout<<"My king, at most "<<len<<" roads can be built."<<endl;
            }
            cout<<endl;
        }
        return 0;
    }
     
  • 相关阅读:
    ReactJS读书笔记一:深入理解JSX
    react经验
    React显示和提交数据
    ReactJS
    PHP中使用memcache
    项目目标文档 ---河北省创新平台年报统计
    系统利益相关者描述案例
    梦断代码 --阅读笔记03
    梦断代码 ---阅读笔记02
    梦断代码---读书笔记01
  • 原文地址:https://www.cnblogs.com/kls123/p/7105470.html
Copyright © 2020-2023  润新知