• Phone List


    Phone List
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 14044   Accepted: 4529

    Description

    Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let's say the phone catalogue listed these numbers:

    • Emergency 911
    • Alice 97 625 999
    • Bob 91 12 54 26

    In this case, it's not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob's phone number. So this list would not be consistent.

    Input

    The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

    Output

    For each test case, output "YES" if the list is consistent, or "NO" otherwise.

    Sample Input

    2
    3
    911
    97625999
    91125426
    5
    113
    12340
    123440
    12345
    98346

    Sample Output

    NO
    YES

    Source

    #include <iostream>
    #include <fstream>
    #include <vector>
    #include <string>
    #include <algorithm>
    #include <map>
    #include <stack>
    #include <cmath>
    #include <queue>
    #include <set>
    #include <list>
    #include <string.h>
    #include <cstdlib>
    #define REP(i,j,k) for( int i = j ; i < k ; ++i)
    #define MAX (100010)


    using namespace std;


    struct Node
    {
    bool isExist;
    int branch[10];

    void clear()
    {
    this->isExist = false;
    REP(i,0,10)
    {
    this->branch[i] = -1;
    }
    }
    };


    Node buff[MAX];
    int size = 0;


    class Trie
    {
    public:
    int root;

    bool insert( char num[] )
    {
    int location = root;
    int i = 0;
    int len = strlen(num);

    for( ; i < len - 1 ; ++i )
    {
    if(buff[location].isExist == true)
    {
    return false;
    }

    if( buff[location].branch[num[i] - '0'] == -1 )
    {
    buff[location].branch[num[i] - '0'] = ++size;
    buff[size].clear();
    }

    location = buff[location].branch[num[i] - '0'];
    }


    if(buff[location].isExist == true)
    {
    return false;
    }

    if(buff[location].branch[num[i] - '0'] == -1 )
    {
    buff[location].branch[num[i] - '0'] = ++size;
    buff[size].clear();
    buff[size].isExist = true;
    }
    else
    {
    return false;
    }

    return true;
    }
    };




    int main()
    {



    int num_case;
    cin >> num_case;

    Trie trie;




    REP(i,0,num_case)
    {
    int num_phone;
    cin >> num_phone;
    bool tag = false;
    size = 0;
    buff[0].clear();
    trie.root = 0;

    REP(j,0,num_phone)
    {
    char phone[11];

    scanf("%s" , phone);

    if( !tag )
    {
    if ( trie.insert(phone) == false)
    {
    tag = true;
    }
    }


    }

    if(!tag)
    {
    cout << "YES" << endl;
    }
    else
    {
    cout << "NO" << endl;
    }
    }

    return 0;

    }
  • 相关阅读:
    PHP小案例
    PHP函数
    PHP基础语法
    PHP基础知识
    tp5.1前台模板的系统变量输出
    PHP常用方法很有意义的博客网址
    VS 2010(2005)Unicode使用cximage库Load函数问题
    坑爹的CFile::Remove
    固定CDockablePane的一些小技巧
    (转)理解Bitblt、StretchBlt与SetDIBitsToDevice、StretchDibits
  • 原文地址:https://www.cnblogs.com/kking/p/2335270.html
Copyright © 2020-2023  润新知