• poj 2481


    Cows
    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 16163   Accepted: 5380

    Description

    Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

    Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

    But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj.

    For each cow, how many cows are stronger than her? Farmer John needs your help!

    Input

    The input contains multiple test cases.
    For each test case, the first line is an integer N (1 <= N <= 105), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 105) specifying the start end location respectively of a range preferred by some cow. Locations are given as distance from the start of the ridge.

    The end of the input contains a single 0.

    Output

    For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi.

    Sample Input

    3
    1 2
    0 3
    3 4
    0
    

    Sample Output

    1 0 0
    

    Hint

    Huge input and output,scanf and printf is recommended.

    Source

    POJ Contest,Author:Mathematica@ZSU
    用树状数组或线段树求解。对奶牛右端点进行降序排序,保证在对奶牛的左端点进行sum操作时,在1~左端点的区间内累计的奶牛都比它强壮。
    树状数组解法
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int n,c[100100],ans[100100];
    struct Cow{
        int s,e,ind;
        bool operator<(const Cow h)const{
            if(e==h.e)return s<h.s;
            return e>h.e;
        }
    }cow[100100];
    inline int lowbit(int x)
    {return x&(-x);}
    inline void add(int x)
    {
        for(int i=x;i<=n;i+=lowbit(i))c[i]++;
    }
    inline int sum(int x)
    {
        int res=0;
        for(int i=x;i>0;i-=lowbit(i))res+=c[i];
        return res;
    }
    int main()
    {
        while(scanf("%d",&n)&&n){
            memset(c,0,sizeof(c));
            for(int i=1;i<=n;i++){
                scanf("%d%d",&cow[i].s,&cow[i].e);
                cow[i].s++;
                cow[i].e++;
                cow[i].ind=i;
            }
            sort(cow+1,cow+1+n);
            for(int i=1;i<=n;i++){
                if(cow[i].s==cow[i-1].s&&cow[i].e==cow[i-1].e)ans[cow[i].ind]=ans[cow[i-1].ind];
                else ans[cow[i].ind]=sum(cow[i].s);
                add(cow[i].s);
            }
            printf("%d",ans[1]);
            for(int i=2;i<=n;i++)printf(" %d",ans[i]);
            puts("");
        }
        return 0;
    }
    

  • 相关阅读:
    how to write a paper
    attention mechanism思考
    OSX-KVM 安装备忘指南: 在KVM虚拟机中运行macOSX Big Sur / Catalina
    Unity CacheServer6.x版本 安装配置说明
    Linux常用命令2
    Ubuntu 18.04 + apache2.4 配置https证书(SSL)笔记
    Linux常用命令随笔
    软件测试-8 集成测试
    软件测试-7 在实际测试时的一些想法
    软件测试-6 白盒测试
  • 原文地址:https://www.cnblogs.com/keshuqi/p/5957784.html
Copyright © 2020-2023  润新知