• uva146 ID codes


    Description

    It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure--all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people's movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.)

    An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set.

    For example, suppose it is decided that a code will contain exactly 3 occurrences of `a', 2 of `b' and 1 of `c', then three of the allowable 60 codes under these conditions are:

          abaabc
          abaacb
          ababac

    These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order.

    Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message `No Successor' if the given code is the last in the sequence for that set of characters.

    Input and Output

    Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single#.

    Output will consist of one line for each code read containing the successor code or the words `No Successor'.

    Sample input

    abaacb
    cbbaa
    #

    Sample output

    ababac
    No Successor

    题目大意:(题外话)George Orwell在《1984》中谈及的老大哥在2084年来到。政府在每个公民体内植入电脑芯片监视控制公民的一举一动,电脑芯片同时具备发射信号的功能。为了确定电脑ID号码,政府给出了一套规则:每个ID号由3个'a'两个'b'一个'c'构成。给定若干ID codes,求它们的下一个字典序全排列。

    思路1:先求出当前排列要变化的子串的首字母下标,若不存在该字母,即已经完成了全排列,则输出No Successor,否则继续算法。再将首字母前一个字母同子串中从后到前第一个字典序大于前者的字母进行交换,之后对子串排序,得出目标(target)数组(array),算法结束。

    思路1:

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    char str[101];
    bool cmp(const char x,const char y)
    {return x<y;}
    int main()
    {
        while(scanf("%s",str)&&str[0]!='#'){
            int k;
            for(k=strlen(str)-1;k>=1;k--)
                if(str[k]>str[k-1])
                    break;
            if(!k){puts("No Successor");continue;}
            for(int i=strlen(str)-1;i>=k;i--)
                if(str[i]>str[k-1])
                {swap(str[i],str[k-1]);break;}
            sort(str+k,str+strlen(str),cmp);
            puts(str);
        }
        return 0;
    }
    

    思路2:直接使用c++ STL标准库中的next_permutation()函数。

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    char str[101];
    int main()
    {
        while(scanf("%s",str)&&str[0]!='#'){
            if(next_permutation(str,str+strlen(str)))
                puts(str);
            else puts("No Successor");
            memset(str,0,sizeof(str));
        }
        return 0;
    }
    



  • 相关阅读:
    如何编译Linux内核
    svn
    windows live writer …
    SVN服务器配置
    使用PowerDesigner创建数据库表图文并茂版
    maven学习
    在PreparedStatement中设置空值
    今天, 我的博客正式开通啦.
    Neo4j简介
    clinit和init(转载)
  • 原文地址:https://www.cnblogs.com/keshuqi/p/5957719.html
Copyright © 2020-2023  润新知