• POJ 2236 Wireless Network



    Wireless Network
    Time Limit: 10000MS   Memory Limit: 65536K
    Total Submissions: 16131   Accepted: 6801

    Description

    An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

    In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

    Input

    The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
    1. "O p" (1 <= p <= N), which means repairing computer p. 
    2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

    The input will not exceed 300000 lines. 

    Output

    For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

    Sample Input

    4 1
    0 1
    0 2
    0 3
    0 4
    O 1
    O 2
    O 4
    S 1 4
    O 3
    S 1 4
    

    Sample Output

    FAIL
    SUCCESS
    

    Source



    哇 ,自己做并查集。一次ac。。

    #include <iostream>
    #include <cstring>
    #define maxn 1005
    using namespace std;
    struct point
    {
        int mast;
        int x,y;
    }f[maxn];
    int find(int x)
    {
        if(f[x].mast==x)
            return x;
        else
            return (f[x].mast=find(f[x].mast));
    }
    int main()
    {
        int n,d;
        cin>>n>>d;
    
        int i;
        for(i=1;i<=n;i++)
        {
            cin>>f[i].x>>f[i].y;
            f[i].mast=i;
        }
    
        char s;
        bool pd[maxn];
        memset(pd,0,sizeof(pd));
    
        while(cin>>s)
        {
            if(s=='S')
            {
                int x,y;
                cin>>x>>y;
    
                if(find(x)==find(y))
                    cout<<"SUCCESS"<<endl;
                else
                    cout<<"FAIL"<<endl;
            }
    
            if(s=='O')
            {
               int x;
               cin>>x;
    
               pd[x]=1;
    
               for(i=1;i<=n;i++)
               {
                   if(pd[i]==1&&i!=x)
                   {
                       if((f[i].x-f[x].x)*(f[i].x-f[x].x)+(f[i].y-f[x].y)*(f[i].y-f[x].y)<=d*d)
                       {
                           int a,b;
                           a=find(i);
                           b=find(x);
                           if(a!=b)
                            f[a].mast=b;
                       }
                   }
               }
            }
        }
        return 0;
    }
    




  • 相关阅读:
    uu467 图片选择修改点
    vant coupon组件使用完整demo不坑人
    一个关于wait/notify与锁关系的探究
    一个简单字符串差异对比暴力算法实现
    基于long pull实现简易的消息中心MQ参考
    three.js(webgl) 课程
    仿照GifCam搞了一个开源的项目,c# wpf prism HandyControl
    fiddler学习——使用fiddler查看请求响应时间
    两小时一起快速搭建个人博客
    C# HttpClient 进度条
  • 原文地址:https://www.cnblogs.com/jzssuanfa/p/6808422.html
Copyright © 2020-2023  润新知