• Argus


    Argus
    Time Limit: 1000MS Memory Limit: 30000K
    Total Submissions: 10186 Accepted: 4801

    Description
    A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.

    Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes."
    Query-2: "Return the average temperature measured on each floor over the past 10 minutes."
    

    We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.

    For the Argus, we use the following instruction to register a query:

    Register Q_num Period
    

    Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds.

    Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num.

    Input
    The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of “#”.

    The second part is your task. This part contains only one line, which is one positive integer K (<= 10000).

    Output
    You should output the Q_num of the first K queries to return the results, one number per line.

    Sample Input

    Register 2004 200
    Register 2005 300
    #
    5

    Sample Output

    2004
    2005
    2004
    2004
    2005

    Source
    Beijing 2004
    优先队列的简单应用

    #include <iostream>
    #include <cmath>
    #include <cstring>
    #include <cstdlib>
    #include <stdio.h>
    #include <string>
    #include <queue>
    #include <algorithm>
    
    using namespace std;
    
    const int INF = 0x3f3f3f3f;
    
    const int MAX = 55000;
    
    struct node
    {
        int ID;
        int Period;
        int time;
    }a;
    
    bool operator < (node b,node c)
    {
        if(b.time>c.time||(b.time==c.time&&b.ID>c.ID))
        {
            return true;
        }
        return false;
    }
    
    int main()
    {
        string c;
        int k;
        priority_queue<node>Q;
        while(cin>>c&&c!="#")
        {
            cin>>a.ID>>a.Period;
            a.time=a.Period;
            Q.push(a);
        }
        cin>>k;
        for(int i=1;i<=k;i++)
        {
            a=Q.top();
            Q.pop();
            cout<<a.ID<<endl;
            a.time+=a.Period;
            Q.push(a);
        }
        return 0;
    }
    
  • 相关阅读:
    linux usb驱动——OTG数据线与普通数据线区别
    linux内核——设置打印信息
    loop设备及losetup命令介绍[转]
    Linux设备(dev)介绍
    开启windows的 admin+开启tel+电源+远程功能
    JL MTK 安防网关的 wifi 吞吐测试
    如何设置默认以管理员权限运行cmd
    docsis cm 上线过程(bigwhite)
    将win7 设置为 NTP服务器
    tshark的抓包和解析
  • 原文地址:https://www.cnblogs.com/juechen/p/5256005.html
Copyright © 2020-2023  润新知