• (POJ2635)The Embarrassed Cryptographer(大数取模)


    The Embarrassed Cryptographer
    Time Limit: 2000MS Memory Limit: 65536K
    Total Submissions: 13041 Accepted: 3516

    Description
    The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
    What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss’ key.

    Input
    The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10100 and 2 <= L <= 106. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.

    Output
    For each number K, if one of its factors are strictly less than the required L, your program should output “BAD p”, where p is the smallest factor in K. Otherwise, it should output “GOOD”. Cases should be separated by a line-break.

    Sample Input

    143 10
    143 20
    667 20
    667 30
    2573 30
    2573 40
    0 0

    Sample Output

    GOOD
    BAD 11
    GOOD
    BAD 23
    GOOD
    BAD 31

    Source
    Nordic 2005
    判断所给的数是不是存在小于L的质因子;
    思路:大数取模,

    #include <set>
    #include <map>
    #include <list>
    #include <stack>
    #include <cmath>
    #include <queue>
    #include <string>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <iostream>
    #include <algorithm>
    #define PI cos(-1.0)
    #define RR freopen("input.txt","r",stdin)
    using namespace std;
    typedef long long LL;
    const int MAX = 1e6+100;
    int Arr[100000];
    int top;
    bool vis[MAX];
    char str[110];
    int b[40];
    int L;
    bool flag;
    int main()
    {
        memset(vis,false,sizeof(vis));
        top=0;
        for(LL i=2;i<MAX;i++)
        {
            if(!vis[i])
            {
                Arr[top++]=i;
                for(LL j=i*i;j<MAX;j+=i)
                {
                    vis[j]=true;
                }
            }
        }
        while(scanf("%s %d",str,&L))
        {
            if(str[0]=='0'&&L==0)
            {
                break;
            }
            flag=false;
            int len=strlen(str);
            int l=0;
            for(int i=len-1;i>=0;i-=3)
            {
                int ans=0;
                for(int j=2;j>=0;j--)
                {
                    if(i-j<0)
                    {
                        continue;
                    }
                    ans=(ans*10+str[i-j]-'0');
                }
                b[l++]=ans;
            }
            int ans;
            for(int i=0;Arr[i]<L;i++)
            {
                ans=0;
                for(int j=l-1;j>=0;j--)
                {
                    ans=(ans*1000+b[j])%Arr[i];
                }
                if(ans==0)
                {
                    cout<<"BAD "<<Arr[i]<<endl;
                    flag=true;
                    break;
                }
            }
            if(!flag)
            {
                cout<<"GOOD"<<endl;
            }
        }
        return 0;
    }
    
  • 相关阅读:
    账户与安全
    VIM 文档编辑
    ubuntu下搭建Discuz
    数据库管理及增删改查基本操作小结
    poj 3320 jessica's Reading PJroblem 尺取法 -map和set的使用
    poj 3579 Median 二分套二分 或 二分加尺取
    poj 3685 Matrix 二分套二分 经典题型
    POJ 3061  Subsequence   尺取法   挑战146页
    poj 2976 Dropping tests 二分搜索+精度处理
    Codeforces Round #325 (Div. 2) A. Alena's Schedule 暴力枚举 字符串
  • 原文地址:https://www.cnblogs.com/juechen/p/5255954.html
Copyright © 2020-2023  润新知