• Financial Management 分类: POJ 2015-06-11 10:51 12人阅读 评论(0) 收藏


    Financial Management
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 164431   Accepted: 61085

    Description

    Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

    Input

    The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

    Output

    The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.

    Sample Input

    100.00
    489.12
    12454.12
    1234.10
    823.05
    109.20
    5.27
    1542.25
    839.18
    83.99
    1295.01
    1.75

    Sample Output

    $1581.42
    要求结果四舍五入
    
    #include <iostream>
    #include  <iomanip>
    #define exp 1e-6
    using namespace std;
    int main()
    {
        double sum=0,data;
        for(int i=0;i<12;i++)
        {
            cin>>data;
            sum+=data;
        }
        sum/=12;
        cout<< "$"<<setiosflags(ios::fixed)<<setprecision(2)<<sum<<endl;
        return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    var 和 let 的区别
    js初步认识变量
    弹性布局
    盒模型
    多重样式优先级深入概念
    层叠机制--比较特殊性
    anroid抓包工具tcpdump的用法
    linux find grep组合使用
    Protect Broadcast 保护广播
    android:exported 属性详解
  • 原文地址:https://www.cnblogs.com/juechen/p/4722042.html
Copyright © 2020-2023  润新知