DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 88690 Accepted: 35644
Description
One measure of unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence
DAABEC”, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence
ZWQM” has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of sortedness'', from
most sorted” to “least sorted”. All the strings are of the same length.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from most sorted'' to
least sorted”. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
大致的意思就是对DNA的逆序数排序
#include <iostream>
#include <string>
#include <algorithm>
#define RR freopen("input.txt","r",stdin)
#define WW freopen("ouput.txt","w",stdout)
using namespace std;
const int INF=0x3f3f3f3f;
int n,m;
struct DNA
{
string str;
int num ;
void NUM()
{
num=0;
for(int i=0;i<n;i++)
{
int sum=0;
for(int j=i-1;j>=0;j--)
{
if(str[i]<str[j])
{
sum++;
}
}
num+=sum;
}
}
}D[110];
bool cmp(DNA a,DNA b)
{
return a.num<b.num;
}
int main()
{
cin>>n>>m;
for(int i=0;i<m;i++)
{
cin>>D[i].str;
D[i].NUM();
}
sort(D,D+m,cmp);
for(int i=0;i<m;i++)
{
cout<<D[i].str<<endl;
}
return 0;
}
版权声明:本文为博主原创文章,未经博主允许不得转载。