• Tautology 分类: POJ 2015-06-28 18:40 10人阅读 评论(0) 收藏


    Tautology
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 10428   Accepted: 3959

    Description

    WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following rules:

    • p, q, r, s, and t are WFFs
    • if w is a WFF, Nw is a WFF
    • if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
    The meaning of a WFF is defined as follows:
    • p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
    • K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.
    Definitions of K, A, N, C, and E
         w  x   Kwx   Awx    Nw   Cwx   Ewx
      1  1   1   1    0   1   1
      1  0   0   1    0   0   0
      0  1   0   1    1   1   0
      0  0   0   0    1   1   1

    A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is not, because it has the value 0 for p=0, q=1.

    You must determine whether or not a WFF is a tautology.

    Input

    Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

    Output

    For each test case, output a line containing tautology or not as appropriate.

    Sample Input

    ApNp
    ApNq
    0

    Sample Output

    tautology
    not
    实在是读不懂什么意思,后来找篇博客,才知道什么意思,英语好渣
    
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <cmath>
    #include <string>
    #include <stack>
    #include <algorithm>
    using namespace std;
    
    const int Max=1100000;
    
    int Arr[6];
    int top;
    string str;
    stack<int>a;
    void Bit(int num)
    {
        int top=0;
        memset(Arr,0,sizeof(Arr));
        while(num)
        {
            Arr[top++]=num%2;
            num/=2;
        }
    }
    bool Jud(char s)
    {
        switch(s)
        {
            case 'p':a.push(Arr[0]);break;
            case 'q':a.push(Arr[1]);break;
            case 'r':a.push(Arr[2]);break;
            case 's':a.push(Arr[3]);break;
            case 't':a.push(Arr[4]);break;
            default :return 0;
        }
        return 1;
    }
    void Count(char s)
    {
        switch(s)
        {
        case 'K':
            {
                int x=a.top();a.pop();
                int y=a.top();a.pop();
                a.push(x&&y);
            }
            break;
        case 'A':
            {
                int x=a.top();a.pop();
                int y=a.top();a.pop();
                a.push(x||y);
            }
            break;
        case 'N':
            {
                 int x=a.top();a.pop();
                 a.push(!x);
            }
            break;
        case 'C':
            {
                int x=a.top();a.pop();
                int y=a.top();a.pop();
                a.push((!x)||y);
            }
            break;
        case 'E':
            {
                int x=a.top();a.pop();
                int y=a.top();a.pop();
                a.push(x==y);
            }
            break;
        }
    }
    bool Cal()
    {
        int len=str.length();
        for(int i=0;i<=31;i++)
        {
            Bit(i);
            for(int j=len-1;j>=0;j--)
            {
                if(!Jud(str[j]))
                {
                    Count(str[j]);
                }
            }
            int x=a.top();
            a.pop();
            if(!x)
                return false;
        }
        return true;
    }
    int main()
    {
        while(cin>>str)
        {
            if(str=="0")
                break;
            if(Cal())
            {
                cout<<"tautology"<<endl;
            }
            else
            {
                cout<<"not"<<endl;
            }
        }
    
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    编译安装centos6.9 php7.0 mysql5.6 nginx1.8
    mysql小细节随笔
    mpdf中文开发使用文档附demo实例
    svn和NetBeans一起使用造成svn老是死锁, database is locked
    Mastering MariaDB 神秘的MariaDB 中文翻译版
    Laravel开发采坑系列问题
    phpspider php爬虫框架
    ajaxFileUpload只能上传一次,和上传同名图片不能上传等bug问题
    bootstrap-treeview 中文开发手册
    phpredis Redis阵列 Redis Arrays
  • 原文地址:https://www.cnblogs.com/juechen/p/4721973.html
Copyright © 2020-2023  润新知