• Help Me with the Game 分类: POJ 2015-06-29 16:34 17人阅读 评论(0) 收藏


    Help Me with the Game
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 3706   Accepted: 2371

    Description

    Your task is to read a picture of a chessboard position and print it in the chess notation.

    Input

    The input consists of an ASCII-art picture of a chessboard with chess pieces on positions described by the input. The pieces of the white player are shown in upper-case letters, while the black player's pieces are lower-case letters. The letters are one of "K" (King), "Q" (Queen), "R" (Rook), "B" (Bishop), "N" (Knight), or "P" (Pawn). The chessboard outline is made of plus ("+"), minus ("-"), and pipe ("|") characters. The black fields are filled with colons (":"), white fields with dots (".").

    Output

    The output consists of two lines. The first line consists of the string "White: ", followed by the description of positions of the pieces of the white player. The second line consists of the string "Black: ", followed by the description of positions of the pieces of the black player.

    The description of the position of the pieces is a comma-separated list of terms describing the pieces of the appropriate player. The description of a piece consists of a single upper-case letter that denotes the type of the piece (except for pawns, for that this identifier is omitted). This letter is immediatelly followed by the position of the piece in the standard chess notation -- a lower-case letter between "a" and "h" that determines the column ("a" is the leftmost column in the input) and a single digit between 1 and 8 that determines the row (8 is the first row in the input).

    The pieces in the description must appear in the following order: King("K"), Queens ("Q"), Rooks ("R"), Bishops ("B"), Knights ("N"), and pawns. Note that the numbers of pieces may differ from the initial position because of capturing the pieces and the promotions of pawns. In case two pieces of the same type appear in the input, the piece with the smaller row number must be described before the other one if the pieces are white, and the one with the larger row number must be described first if the pieces are black. If two pieces of the same type appear in the same row, the one with the smaller column letter must appear first.

    Sample Input

    +---+---+---+---+---+---+---+---+
    |.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|
    +---+---+---+---+---+---+---+---+
    |:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|
    +---+---+---+---+---+---+---+---+
    |...|:::|.n.|:::|...|:::|...|:p:|
    +---+---+---+---+---+---+---+---+
    |:::|...|:::|...|:::|...|:::|...|
    +---+---+---+---+---+---+---+---+
    |...|:::|...|:::|.P.|:::|...|:::|
    +---+---+---+---+---+---+---+---+
    |:P:|...|:::|...|:::|...|:::|...|
    +---+---+---+---+---+---+---+---+
    |.P.|:::|.P.|:P:|...|:P:|.P.|:P:|
    +---+---+---+---+---+---+---+---+
    |:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|
    +---+---+---+---+---+---+---+---+
    

    Sample Output

    White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4
    Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6
    大模拟
    
    #include <iostream>
    #include <cstring>
    #include <cstdio>
    #include <cmath>
    #include <string>
    #include <stack>
    #include <queue>
    #include <vector>
    #include <algorithm>
    using namespace std;
    
    const int Max=1100000;
    
    char s[110][110];
    
    char str[110];
    
    char c[]={'K','Q','R','B','N','P'};
    
    int main()
    {
        for(int i=8;i>=1;i--)
        {
            scanf("%s",str);
            scanf("%s",s[i]);
        }
        scanf("%s",str);
        cout<<"White: ";
        bool flag=false;
        for(int i=0;i<6;i++)
        {
            for(int j=1;j<=8;j++)
            {
                int sum=0;
                for(int k=2;k<33;k+=4,sum++)
                {
                    if(c[i]==s[j][k]&&c[i]!='P')
                    {
                        if(!flag)
                        {
                            printf("%c%c%d",c[i],'a'+sum,j);
                            flag=true;
                        }
                        else
                        {
                            printf(",%c%c%d",c[i],'a'+sum,j);
                        }
                    }
                    else if(c[i]==s[j][k]&&c[i]=='P')
                    {
                        if(!flag)
                        {
                           printf("%c%d",'a'+sum,j);
                            flag=true;
                        }
                        else
                        {
                            printf(",%c%d",'a'+sum,j);
                        }
                    }
                }
            }
        }
        cout<<endl;
        cout<<"Black: ";
        flag=false;
        for(int i=0;i<6;i++)
        {
            for(int j=8;j>=1;j--)
            {
                int sum=0;
                for(int k=2;k<33;k+=4,sum++)
                {
                    if(c[i]+32==s[j][k]&&c[i]!='P')
                    {
                        if(!flag)
                        {
                            printf("%c%c%d",c[i],'a'+sum,j);
                            flag=true;
                        }
                        else
                        {
                            printf(",%c%c%d",c[i],'a'+sum,j);
                        }
                    }
                    else if(c[i]+32==s[j][k]&&c[i]=='P')
                    {
                        if(!flag)
                        {
                           printf("%c%d",'a'+sum,j);
                            flag=true;
                        }
                        else
                        {
                            printf(",%c%d",'a'+sum,j);
                        }
                    }
                }
            }
        }
        cout<<endl;
        return 0;
    }
    


    版权声明:本文为博主原创文章,未经博主允许不得转载。

  • 相关阅读:
    Eclipse 读取config目录下文件
    cakephp 中Console / Shell 有什么优点?
    cakephp中使用 find('count')方法
    [转]using components in Cakephp 2+ Shell
    [转]Git for windows 下vim解决中文乱码的有关问题
    在Foxmail中添加阿里云企业邮箱账号
    Cakephp在Controller中显示sql语句
    java线程的基本概念
    mysql varchar到底能存多少字符。
    mysql 联合索引匹配原则
  • 原文地址:https://www.cnblogs.com/juechen/p/4721969.html
Copyright © 2020-2023  润新知