• 最大连续和


    P3009 [USACO11JAN]利润Profits

    题目描述

    The cows have opened a new business, and Farmer John wants to see how well they are doing. The business has been running for N (1 <= N <= 100,000) days, and every day i the cows recorded their net profit P_i (-1,000 <= P_i <= 1,000).

    Farmer John wants to find the largest total profit that the cows have made during any consecutive time period. (Note that a consecutive time period can range in length from one day through N days.) Help him by writing a program to calculate the largest sum of consecutive profits.

    牛们开了家新公司,这家公司已经运作了N天,财务报表显示第i天获得的利润为Pi , 有些天的利润可能是个负数。约翰想给奶牛公司写个新闻报道,以吹嘘她们的业绩。于是他 想知道,这家公司在哪一段连续的日子里,利润总和是最大的。

    输入输出格式

    输入格式:
    Line 1: A single integer: N

    Lines 2..N+1: Line i+1 contains a single integer: P_i
    输出格式:
    Line 1: A single integer representing the value of the maximum sum of profits for any consecutive time period.
    输入输出样例

    输入样例#1:
    7
    -3
    4
    9
    -2
    -5
    8
    -3
    输出样例#1:
    14
    说明

    The maximum sum is obtained by taking the sum from the second through the sixth number (4, 9, -2, -5, 8) => 14.

    解法

    依次扫描。currsum保存上一个数结尾的最大和,maxsum保存全局最大和。那么碰到一个新的数x,有两种行为,一种是以它为头建立一个新的连续序列,一种是把它放在上一个数所在的序列的结尾,看哪个得到的和大一点就用哪个。

    注意初始化要比数据范围下界小。

    #include <algorithm>
    #include <iostream>
    
    using namespace std;
    
    int main(void) {
        int n;
        cin >> n;
        
        int currsum = -2000;
        int maxsum  = -2000;
        
        for (int i = 0; i < n; ++i) {
            int x;
            cin >> x;
            
            currsum = max(x, x+currsum);
            maxsum  = max(maxsum, currsum);
        }
        
        cout << maxsum;
    }
    
  • 相关阅读:
    CVE-20117-111882漏洞复现及利用
    如何查看QQ坦白说来自谁
    2018 巅峰极客CTF misc writeup
    屏幕截图
    Unity中设置屏幕常亮
    面向对象设计原则
    【转】Unity资源管理原理知识(干货不嫌长)
    给指定的图片增加水印
    统计一个目录下各种文件类型及个数
    JDK 开发环境配置
  • 原文地址:https://www.cnblogs.com/jt2001/p/6130399.html
Copyright © 2020-2023  润新知