• 博弈论入门题 kiki's game


    Problem Description
    Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
     
    Input
    Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

     
    Output
    If kiki wins the game printf "Wonderful!", else "What a pity!".
     
    Sample Input
    5 3 5 4 6 6 0 0
     
    Sample Output
    What a pity! Wonderful! Wonderful!
     
    Author
    月野兔
     
    Source
     
    Recommend
    威士忌   |   We have carefully selected several similar problems for you:  1846 1847 1848 1849 1517 
     
     
     
    显然(1,1)是必败态,因为没有操作可以选择
    那么由必胜态的定义(一步之内能走到必败态的状态叫必胜态)(1,2),(2,2),(2,1)都是必胜态
    依次类推可以打一个表出来(必败态:下一步无论怎样转移都会转移到必胜态)
    找规律
    n,m都是奇数的时候会输!
    #include<iostream>
    #include<cstdio>
    #include<cmath>
    #include<cstring>
    #include<sstream>
    #include<algorithm>
    #include<queue>
    #include<deque>
    #include<iomanip>
    #include<vector>
    #include<cmath>
    #include<map>
    #include<stack>
    #include<set>
    #include<functional>
    #include<fstream>
    #include<memory>
    #include<list>
    #include<string>
    using namespace std;
    typedef long long LL;
    typedef unsigned long long ULL;
    
    #define N 100
    #define MAXN 20000 + 9
    #define INF 1000000009
    #define eps 0.00000001
    #define sf(a) scanf("%d",&a)
    
    int n;
    int a[N];
    int main()
    {
        while (sf(n), n)
        {
            int sum = 0;
            for (int i = 0; i < n; i++)
                sf(a[i]), sum ^= a[i];
            if (sum == 0)
                cout << 0 << endl;
            else
            {
                int ans = 0;
                for (int i = 0; i < n; i++)
                {
                    if ((sum^a[i]) < a[i])
                        ans++;
                }
                cout << ans << endl;
            }
        }
    }
  • 相关阅读:
    还是模块
    模块
    Django之中间件和Auth模块
    Django之form表单组件、cookie与session
    ORM表查询之F查询和Q查询以及事务
    django之单表和多表查询
    django之模板层
    Django之路由
    Django之前戏
    前端之Bootstrap框架
  • 原文地址:https://www.cnblogs.com/joeylee97/p/7497420.html
Copyright © 2020-2023  润新知