• Spell checker POJ 1035 字符串


    Spell checker
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 25426   Accepted: 9300

    Description

    You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
    If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
    ?deleting of one letter from the word; 
    ?replacing of one letter in the word with an arbitrary letter; 
    ?inserting of one arbitrary letter into the word. 
    Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

    Input

    The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
    The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
    All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

    Output

    Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

    Sample Input

    i
    is
    has
    have
    be
    my
    more
    contest
    me
    too
    if
    award
    #
    me
    aware
    m
    contest
    hav
    oo
    or
    i
    fi
    mre
    #

    Sample Output

    me is correct
    aware: award
    m: i my me
    contest is correct
    hav: has have
    oo: too
    or:
    i is correct
    fi: i
    mre: more me
    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstring>
    #include<vector>
    #include<string>
    using namespace std;
    typedef long long LL;
    #define MAXN 10003
    /*
    给定词典中的单词,要求检查合法的单词
    如果词典中单词与该单词长度相等检查能否替换
    否则如果两个单词长度之差绝对值小于一 检查能否添加删除
    */
    vector<string> dict;
    bool f = false;
    bool Compare(string &s,string &l)
    {
        string::iterator p1 = s.begin(),p2 = l.begin();
        int cnt = 0;
        while(p1!=s.end())
        {
            if(*p1!=*p2)
            {
                p2++;
                cnt++;
                if(cnt>1)
                    return false;
            }
            else
            {
                p1++;
                p2++;
            }
        }
        return true;
    }
    bool Replace(string &word,string &dict)
    {
        int l = word.size();
        int cnt = 0;
        for(int i=0;i<l;i++)
        {
            if(word[i]!=dict[i])
                cnt++;
            if(cnt>1)
                return false;
        }
        return true;
    }
    int main()
    {
        dict.resize(10001);
        int cnt = 0;
        while(cin>>dict[cnt++])
        {
            if(dict[cnt-1][0]=='#')
            {
                cnt--;
                break;
            }
        }
        string word;
        while(cin>>word)
        {
            vector<string> ans;
            if(word[0]=='#')
                break;
            int l1 = word.size();
            f = false;
            bool find =  false;
            for(int i=0;i<cnt;i++)
            {
                int l2 = dict[i].size();
                if(l1==l2)
                {
                    if(word==dict[i])
                    {
                        find = true;
                        f = false;
                        break;
                    }
                    if(Replace(word,dict[i]))
                    {
                        f = true;
                        ans.push_back(dict[i]);
                    }
                }
                else if(l1==l2+1)
                {
                    if(Compare(dict[i],word))
                    {
                        f = true;
                        ans.push_back(dict[i]);
                    }
                }
                else if(l2==l1+1)
                {
                    if(Compare(word,dict[i]))
                    {
                        f = true;
                        ans.push_back(dict[i]);
                    }
                }
            }
            cout<<word;
            if(!f&&find)
                cout<<" is correct";
            else
            {
                cout<<":";
                for(int i=0;i<ans.size();i++)
                    cout<<" "<<ans[i];
            }
            cout<<endl;
        }
    }
  • 相关阅读:
    各位AS3各种验证在这里,邮箱 身份证 ...
    各位同学还在为AS3在IE透明模式下弹出新窗口而烦恼吗?
    Flash As3 通过二进制[ByteArray]判断真实的文件类型
    【A8笔记1】Alternativa 8.5.0 在Flash、Fb、Fd中的配置
    超酷光带效果
    flash 墙
    A3D CoverFlow图片展示效果
    Windows8Metro模式IE10放弃Flash的支持
    html5 控件整理
    AS3中JSON的基本应用实例
  • 原文地址:https://www.cnblogs.com/joeylee97/p/6662093.html
Copyright © 2020-2023  润新知