• 算法竞赛入门经典5.2 STL初步


    1.  排序和检索,学会使用sort排序,以及low_bound函数

    Raju and Meena love to play with Marbles. They have got a lot of marbles with numbers written on them. At the beginning, Raju would place the marbles one after another in ascending order of the numbers written on them. Then Meena would ask Raju to find the first marble with a certain number. She would count 1...2...3. Raju gets one point for correct answer, and Meena gets the point if Raju fails. After some fixed number of trials the game ends and the player with maximum points wins. Today it’s your chance to play as Raju. Being the smart kid, you’d be taking the favor of a computer. But don’t underestimate Meena, she had written a program to keep track how much time you’re taking to give all the answers. So now you have to write a program, which will help you in your role as Raju.

    Input

    There can be multiple test cases. Total no of test cases is less than 65. Each test case consists begins with 2 integers: N the number of marbles and Q the number of queries Mina would make. The next N lines would contain the numbers written on the N marbles. These marble numbers will not come in any particular order. Following Q lines will have Q queries. Be assured, none of the input numbers are greater than 10000 and none of them are negative. Input is terminated by a test case where N = 0 and Q = 0.

    Output

    For each test case output the serial number of the case. For each of the queries, print one line of output. The format of this line will depend upon whether or not the query number is written upon any of the marbles. The two different formats are described below: • ‘x found at y’, if the first marble with number x was found at position y. Positions are numbered 1, 2, . . . , N. • ‘x not found’, if the marble with number x is not present. Look at the output for sample input for details.

    Sample Input

    4 1 2 3 5 1 5 5 2 1 3 3 3 1 2 3 0 0

    Sample Output

    CASE# 1: 5 found at 4

    CASE# 2: 2 not found 3 found at 3

    #include <iostream>
    #include <stdio.h>
    #include <string>
    #include <string.h>
    #include <algorithm>
    #include <map>
    #include <set>
    #include <queue>
    #include <stack>
    using namespace std;
    
    const int maxn = 10005;
    int N,Q;
    int temp;
    int casee=1;
    int a[maxn];
    
    int main()
    {
        while(cin>>N>>Q)
        {
            if(N==0&&Q==0)
                break;
            else
            {
                cout<<"CASE# "<<casee++<<":"<<endl;
                for(int i=0;i<N;i++)
                    cin>>a[i];
                sort(a,a+N);//排序,可以自己手写cmp函数作为参数,一般是用在结构体里面排序。
                while(Q--)
                {
                    cin>>temp;
                    int flag=lower_bound(a,a+N,temp)-a;//在已经排序的数组里面寻找x
                    if(a[flag]==temp)
                        cout<<temp<<" found at "<<flag+1<<endl;
                    else
                        cout<<temp<<" not found"<<endl;
                }
            }
        }
        return 0;
    }

     

    2.  vector的用法。

    常用函数,push_back() 尾部添加元素     pop_back() 删除最后一个元素  size() 返回长度  resize(b) 改变大小,保留下标0—b之间的元素

    reverse(vec.begin(),vec.end());将元素翻转,即逆序排列!

    vector元素遍历利用迭代器  for(vector<int>::iterator it = v.begin();it!=v.end();it++)

                   { cout<<*it<<" "; }

    UVA-101

    题目链接https://vjudge.net/problem/UVA-101

    #include <iostream>
    #include <stdio.h>
    #include <string>
    #include <string.h>
    #include <algorithm>
    #include <map>
    #include <set>
    #include <queue>
    #include <stack>
    #include <vector>
    using namespace std;
    
    const int maxn=30;
    vector<int>v[maxn];
    int n;
    string s1,s2;
    int a,b;
    
    void findd(int a,int &p,int &h)
    {
        for(p=0;p<n;p++)
        {
            for(h=0;h<v[p].size();h++)
            {
                if(v[p][h]==a)
                    return;
            }
        }
    }
    
    void fun1(int p,int h)//归位
    {
        for(int i=h+1;i<v[p].size();i++)
        {
            int j=v[p][i];
            v[j].push_back(j);
        }
        v[p].resize(h+1);
    }
    
    void fun2(int p1,int h,int p2)
    {
        for(int i=h;i<v[p1].size();i++)
            v[p2].push_back(v[p1][i]);
        v[p1].resize(h);
    }
    
    int main()
    {
        cin>>n;
        for(int i=0;i<n;i++)
            v[i].push_back(i);
        while(cin>>s1)
        {
            if(s1=="quit")
                break;
            cin>>a>>s2>>b;
            int pa,ha,pb,hb;
            findd(a,pa,ha);
            findd(b,pb,hb);
            if(pa==pb)
                continue;
            //cout<<pa<<" "<<ha<<" "<<pb<<" "<<hb<<endl;
            if(s2=="onto")
                fun1(pb,hb);
            if(s1=="move")
                fun1(pa,ha);
            fun2(pa,ha,pb);
        }
        for(int i=0;i<n;i++)
        {
            cout<<i<<":";
            for(int j=0;j<v[i].size();j++)
                cout<<" "<<v[i][j];
            cout<<endl;
        }
        return 0;
    }

     

  • 相关阅读:
    SQL Server中六种数据移动的方法
    SQL Server数据导入导出技术概述与比较
    深入浅出SQL之左连接、右连接和全连接
    安装SQL server提示安装不上,挂起之类
    如何在SQL Server中快速删除重复记录
    SQL Server数据导入导出工具BCP详解
    深入浅出SQL教程之嵌套SELECT语句
    使用osql执行sql脚本
    sql server 分组统计
    php常用几种设计模式的应用场景
  • 原文地址:https://www.cnblogs.com/jkzr/p/9589414.html
Copyright © 2020-2023  润新知