• Calendar


    Calendar

    Time Limit: 1 Sec  Memory Limit: 64 MB
    Submit: 351  Solved: 124
    [Submit][Status][Discuss]

    Description

    A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system. According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years. Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.

    Input

    The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer -1, which should not be processed. You may assume that the resulting date won't be after the year 9999.

    Output

    For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".

    Sample Input

    1730
    1740
    1750
    1751
    -1

    Sample Output

    2004-09-26 Sunday
    2004-10-06 Wednesday
    2004-10-16 Saturday
    2004-10-17 Sunday
    首先需要注意闰年的计算方法:闰年判定:能被400整除,或者能被4整除但不能被100整除。其余的年份都为平年。

    然后计算月份的时候可以将月份存入一个数组,依次循环。


    #include <stdio.h>

    int main()
    {
        for(;;)
        {
            int n,i,k,m,u;
            scanf("%d",&n);
            if(n==-1)
                break;
            n=n+1;u=n;
            for(m=2000;;m++)
            {
                if((m%4==0&&m%100!=0)||(m%400==0))
                   {
                       n=n-366;
                       if(n<0)
                       {n=n+366;m=m-1;break;}
                   }
                else
                    {
                        n=n-365;
                        if(n<0)
                        {n=n+365;m=m-1;break;}
                    }
                if(((m+1)%4==0&&(m+1)%100!=0)||((m+1)%400==0))
                  if(n<366)
                    break;
                if(n<365)
                    break;
            }
            if(n==0)
            {
                printf("%d-12-31 ",m);
                if(u%7==0)
                    printf("Friday ");
                if(u%7==1)
                    printf("Saturday ");
                if(u%7==2)
                    printf("Sunday ");
                if(u%7==3)
                    printf("Monday ");
                if(u%7==4)
                    printf("Tuesday ");
                if(u%7==5)
                    printf("Wednesday ");
                if(u%7==6)
                    printf("Thursday ");
                continue;
            }
            int a[12]={31,28,31,30,31,30,31,31,30,31,30,31};
            if(((m+1)%4==0&&(m+1)%100!=0)||((m+1)%400==0))
                a[1]=29;
            for(i=0;i<12;i++)
            {
                n=n-a[i];
                if(n<=0)
                {
                    k=i+1;n=n+a[i];break;
                }
            }
            printf("%d-%02d-%02d ",m+1,k,n);
                if(u%7==0)
                    printf("Friday ");
                if(u%7==1)
                    printf("Saturday ");
                if(u%7==2)
                    printf("Sunday ");
                if(u%7==3)
                    printf("Monday ");
                if(u%7==4)
                    printf("Tuesday ");
                if(u%7==5)
                    printf("Wednesday ");
                if(u%7==6)
                    printf("Thursday ");


        }
        return 0;
    }

  • 相关阅读:
    重新整理数据结构与算法(c#)—— 树的节点删除[十八]
    重新整理数据结构与算法(c#系列)—— 树的前中后序遍历查找[十七]
    重新整理数据结构与算法(c#系列)—— 树的前中后序遍历[十六]
    js es6 标签模板还原字符串
    MVC过滤器简单刨析
    MVC 测试action的运行速度
    MVC如何创建区域
    软件——IDEA 超实用使用技巧分享
    前端——Vue-cli 通过UI页面创建项目
    软件——IDEA中如何去掉警告虚线
  • 原文地址:https://www.cnblogs.com/jk17211764/p/9677423.html
Copyright © 2020-2023  润新知