• HDU1070:Milk


    Problem Description
    Ignatius drinks milk everyday, now he is in the supermarket and he wants to choose a bottle of milk. There are many kinds of milk in the supermarket, so Ignatius wants to know which kind of milk is the cheapest.

    Here are some rules:
    1. Ignatius will never drink the milk which is produced 6 days ago or earlier. That means if the milk is produced 2005-1-1, Ignatius will never drink this bottle after 2005-1-6(inclusive).
    2. Ignatius drinks 200mL milk everyday.
    3. If the milk left in the bottle is less than 200mL, Ignatius will throw it away.
    4. All the milk in the supermarket is just produced today.

    Note that Ignatius only wants to buy one bottle of milk, so if the volumn of a bottle is smaller than 200mL, you should ignore it.
    Given some information of milk, your task is to tell Ignatius which milk is the cheapest.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case starts with a single integer N(1<=N<=100) which is the number of kinds of milk. Then N lines follow, each line contains a string S(the length will at most 100 characters) which indicate the brand of milk, then two integers for the brand: P(Yuan) which is the price of a bottle, V(mL) which is the volume of a bottle.
     
    Output
    For each test case, you should output the brand of the milk which is the cheapest. If there are more than one cheapest brand, you should output the one which has the largest volume.
     
    Sample Input
    2 2 Yili 10 500 Mengniu 20 1000 4 Yili 10 500 Mengniu 20 1000 Guangming 1 199 Yanpai 40 10000
     
    Sample Output
    Mengniu Mengniu
    Hint
    In the first case, milk Yili can be drunk for 2 days, it costs 10 Yuan. Milk Mengniu can be drunk for 5 days, it costs 20 Yuan. So Mengniu is the cheapest.In the second case, milk Guangming should be ignored. Milk Yanpai can be drunk for 5 days, but it costs 40 Yuan. So Mengniu is the cheapest.
     
    #include <stdio.h>
    
    struct Milk
    {
        char name[1000];
        int p,v;
    } milk[100000];
    
    int main()
    {
        int t,i,flag,n;
        scanf("%d",&n);
        while(n--)
        {
            scanf("%d",&t);
            double m = 0;
            for(i = 0; i<t; i++)
            {
                scanf("%s%d%d",milk[i].name,&milk[i].p,&milk[i].v);
                int cnt = 0;
                if(milk[i].v < 200)
                    continue;
                while(1)
                {
                    milk[i].v-=200;
                    cnt++;
                    if(cnt == 5)
                        break;
                    if(milk[i].v <200)
                        break;
                }
                double k = (double)cnt/milk[i].p;//性价比
                if(k >= m)
                {
                    if(k > m )//取性价比最大的
                    {
                        m = k;
                        flag = i;
                    }
                    if(k == m)
                    {
                        if(milk[i].p < milk[flag].p)//性价比一样取便宜的
                            flag = i;
                        else if(milk[i].p == milk[flag].p)//价格也一样取容量大的
                        {
                            if(milk[i].v > milk[flag].v)
                                flag = i;
                        }
                    }
                }
            }
            printf("%s\n",milk[flag].name);
        }
    
        return 0;
    }
    



  • 相关阅读:
    【Little Demo】左右按钮tab选项卡双切换
    【Little Demo】从简单的Tab标签到Tab图片切换
    前端工程师说明(仅以自勉)
    CSS 布局整理
    【Javascript Demo】图片瀑布流实现
    【jQuery Demo】图片瀑布流实现
    【CSS Demo】纯 CSS 打造 Flow-Steps 导航
    【CSS Demo】网站页面变灰
    gradlew命令
    Fragment中不能使用自定义带参构造函数
  • 原文地址:https://www.cnblogs.com/jiangu66/p/3000357.html
Copyright © 2020-2023  润新知