链接:http://acm.hdu.edu.cn/showproblem.php?pid=1003
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is
to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7),
the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer
T(1<=T<=20) which means the number of test cases. Then T lines follow,
each line starts with a number N(1<=N<=100000), then N integers
followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The
first line is "Case #:", # means the number of the test case. The second line
contains three integers, the Max Sum in the sequence, the start position of the
sub-sequence, the end position of the sub-sequence. If there are more than one
result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
简单的动态规划,最大子串和;
/********* hdu 1003 ************/
/********* 琴心&剑胆 ************/
/********* 2011/5/9 ************/
#include<stdio.h>
int main(){
int T;
scanf( "%d",&T );
int M=T;
while( T-- ){
int n;
scanf( "%d",&n );
int a[n],ts=0,ti=0,s=0,bi=0,bj=n-1,f=0,max=-32767,mi;
for( int i=0;i<n;++i ){
scanf( "%d",&a[i] );
if(max<a[i]){
max=a[i];
mi=i;
}
if( a[i]<0 )
f++;
ts+=a[i];
if(ts<0){
ts=0;
ti=i+1;
}
if(s<ts){
s=ts;
bj=i;
bi=ti;
}
}
printf("Case %d:\n",M-T);
if( f==n )
printf( "%d %d %d\n",max,mi+1,mi+1 );
else
printf( "%d %d %d\n",s,bi+1,bj+1 );
if( T )
printf("\n");
}
}