• poj1552


                                          Doubles
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 18824   Accepted: 10846

    Description

    As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list
    1 4 3 2 9 7 18 22

    your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

    Input

    The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

    Output

    The output will consist of one line per input list, containing a count of the items that are double some other item.

    Sample Input

    1 4 3 2 9 7 18 22 0
    2 4 8 10 0
    7 5 11 13 1 3 0
    -1

    Sample Output

    3
    2
    0

    Source

    Mid-Central USA 2003
    #include <iostream>
    #include<cstring>
    using namespace std;
    
    int main()
    {
        int a[20];
        cin>>a[0];
        while(a[0]!=-1)
        {
            int n =1;
            int ans = 0;
            for(;;n++)
            {
                cin>>a[n];
                if(a[n]==0)
                    break;
            }
            for(int i=0;i<n-1;i++)
            {
                for(int j=i+1;j<n;j++)
                    if(a[i]*2==a[j]||a[i]==a[j]*2)
                    ans++;
            }
            cout<<ans<<endl;
            memset(a,0,sizeof(a));
            cin>>a[0];
        }
        return 0;
    }
  • 相关阅读:
    [20170612]FOR ALL COLUMNS SIZE repeat(11g).txt
    [20170612]FOR ALL COLUMNS SIZE repeat(12c).txt
    [20170611]关于数据块地址的计算.txt
    [20170607]再论Private Strand Flush Not Complete.txt
    [20170606]11G _optimizer_null_aware_antijoin.txt
    42_自定义泛型类的应用
    43_通过反射获得泛型的实际类型参数
    为什么好男孩找不到女朋友
    38_泛型的通配符扩展应用
    36_入门泛型的基本应用
  • 原文地址:https://www.cnblogs.com/jhldreams/p/3748082.html
Copyright © 2020-2023  润新知