• uva 11234


    Problem E: Expressions

    Arithmetic expressions are usually written with the operators in between the two operands (which is called infix notation). For example, (x+y)*(z-w) is an arithmetic expression in infix notation. However, it is easier to write a program to evaluate an expression if the expression is written in postfix notation (also known as reverse polish notation). In postfix notation, an operator is written behind its two operands, which may be expressions themselves. For example, x y + z w - * is a postfix notation of the arithmetic expression given above. Note that in this case parentheses are not required.

    To evaluate an expression written in postfix notation, an algorithm operating on a stack can be used. A stack is a data structure which supports two operations:

    1. push: a number is inserted at the top of the stack.
    2. pop: the number from the top of the stack is taken out.

    During the evaluation, we process the expression from left to right. If we encounter a number, we push it onto the stack. If we encounter an operator, we pop the first two numbers from the stack, apply the operator on them, and push the result back onto the stack. More specifically, the following pseudocode shows how to handle the case when we encounter an operator O:

    a := pop();
    b := pop();
    push(b O a);

    The result of the expression will be left as the only number on the stack.

    Now imagine that we use a queue instead of the stack. A queue also has a push and pop operation, but their meaning is different:

    1. push: a number is inserted at the end of the queue.
    2. pop: the number from the front of the queue is taken out of the queue.

    Can you rewrite the given expression such that the result of the algorithm using the queue is the same as the result of the original expression evaluated using the algorithm with the stack?

    Input Specification

    The first line of the input contains a number T (T ≤ 200). The following T lines each contain one expression in postfix notation. Arithmetic operators are represented by uppercase letters, numbers are represented by lowercase letters. You may assume that the length of each expression is less than 10000 characters.

    Output Specification

    For each given expression, print the expression with the equivalent result when using the algorithm with the queue instead of the stack. To make the solution unique, you are not allowed to assume that the operators are associative or commutative.

    Sample Input

    2
    xyPzwIM
    abcABdefgCDEF
    

    Sample Output

    wzyxIPM
    gfCecbDdAaEBF

    #include <iostream>
    #include <stack>
    #include <cstring>
    #include <cstdio>
    #include <string>
    #include <algorithm>
    #include <queue>
    #include <set>
    #include <map>
    #include <fstream>
    #include <stack>
    #include <list>
    #include <sstream>
    
    using namespace std;
    
    #define ms(arr, val) memset(arr, val, sizeof(arr))
    #define N 50000
    #define INF 0x3fffffff
    #define vint vector<int>
    #define setint set<int>
    #define mint map<int, int>
    #define lint list<int>
    #define sch stack<char>
    #define qch queue<char>
    #define sint stack<int>
    #define qint queue<int>
    
    struct btree
    {
        int l;
        int r;
    }bt[N];
    
    char post[N];
    sint si;
    qint qi;
    sch sc;
    
    void build(int i)//建立二叉树(后序遍历左右中)bt和post下标一致
    {
        while (post[i])
        {
            if (islower(post[i]))
            {
                bt[i].l = bt[i].r = 0;
            }
            else
            {
                bt[i].r = si.top();
                si.pop();
                bt[i].l = si.top();
                si.pop();
            }
            si.push(i++);
        }
    }
    void bfs()
    {
        int t = si.top();
        qi.push(t);//根节点下标压栈
        sc.push(post[t]);
        si.pop();
        while (!qi.empty())
        {
            t = qi.front();
            qi.pop();
            if (bt[t].l)
            {
                qi.push(bt[t].l);
                sc.push(post[bt[t].l]);
            }
            if (bt[t].r)
            {
                qi.push(bt[t].r);
                sc.push(post[bt[t].r]);
            }
        }
        while (!sc.empty())
        {
            cout<<sc.top();
            sc.pop();
        }
        cout<<endl;
    }
    int main()
    {
        int n;
        cin>>n;
        getchar();
        while (n--)
        {
            gets(post + 1);
            build(1);
            bfs();
        }
        return 0;
    }
  • 相关阅读:
    Ubuntu安装deb软件包错误(依赖关系问题)解决
    scrapy抓取的中文结果乱码解决办法
    删除Git记录里的大文件
    Ubuntu18.04 修改DNS
    linux实现ssh免密码登录
    Vim进阶指南
    查找相同图片并重命名
    Markdown进阶指南
    一眼看穿flatMap和map的区别
    Java8简明指南
  • 原文地址:https://www.cnblogs.com/jecyhw/p/3902998.html
Copyright © 2020-2023  润新知