• 4321(贪心)


    Problem Description

    When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

    There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

    To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

    Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.

    Input

    The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)

    Output

    Output one line for each test, indicates the minimum HP loss.

    Sample Input

    1
    10 2
    2
    100 1
    1 100
    

    Sample Output

    20
    201
    

    #include<stdio.h>
    struct n
    {
        int hp,dps;
    };
    int main()
    {
        int n,i,j;
        __int64 sdps,sum;
         struct n  a[25],tem;
        while(scanf("%d",&n)==1)
        {
            sdps=0; sum=0;
            for(i=0;i<n;i++)
            {
                scanf("%d%d",&a[i].hp,&a[i].dps);
                sdps+=a[i].dps;
            }
    
            for(i=0;i<n;i++)
            for(j=i+1;j<n;j++)
            {
                if(a[i].dps*1.0/a[i].hp<a[j].dps*1.0/a[j].hp)
                {
                    tem=a[i];a[i]=a[j];a[j]=tem;
                }
            }
            for(i=0;i<n;i++)
            {
                sdps-=a[i].dps;
                sum+=a[i].hp*(sdps+a[i].dps);
            }
            printf("%I64d\n",sum);
        }
    }
    
    /*2
    30 1000
    1 50*/


     

  • 相关阅读:
    LINUX的SSH下FTP到远程服务器Entering Passive Mode失败解决
    LINUX的SSH下FTP到远程服务器Entering Passive Mode失败解决
    LINUX的SSH下FTP到远程服务器Entering Passive Mode失败解决
    git rm简介
    git rm简介
    git rm简介
    linux rz -e
    新版住院电子病历首页 (2012年修订说明)
    DateEdit和TimeEdit用法
    ORA-22868: 具有 LOB 的表包含有位于不同表空间的段
  • 原文地址:https://www.cnblogs.com/javawebsoa/p/3112988.html
Copyright © 2020-2023  润新知