• POJ1562:Oil Deposits(DFS) java程序员


    Oil Deposits
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 9814   Accepted: 5375

    Description

    The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

    Input

    The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket. 

    Output

    are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

    Sample Input

    1 1
    *
    3 5
    *@*@*
    **@**
    *@*@*
    1 8
    @@****@*
    5 5 
    ****@
    *@@*@
    *@**@
    @@@*@
    @@**@
    0 0

    Sample Output

    0
    1
    2
    2
    

    Source

    MYCode:
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    using namespace std;
    #define MAX 110
    int n,m;
    char map[MAX][MAX];
    bool vis[MAX][MAX];
    int dirt[8][2]={{1,0},{-1,0},{0,1},{0,-1},{1,-1},{1,1},{-1,1},{-1,-1}};
    void init()
    {
        memset(vis,0,sizeof(vis));
    }
    void dfs(int x,int y)
    {
        vis[x][y]=true;
        int i;
        int tx,ty;
        for(i=0;i<8;i++)
        {
            tx=x;
            ty=y;
            tx+=dirt[i][0];
            ty+=dirt[i][1];
            if(1<=tx&&tx<=n&&1<=ty&&ty<=m&&map[tx][ty]=='@'&&!vis[tx][ty])
            {
                dfs(tx,ty);
            }
        }
    }
    int main()
    {
        while(scanf("%d%d",&n,&m)!= EOF)
        {
            if(n==0)
            break;
            init();
            int i,j;
            for(i=1;i<=n;i++)
            {
                for(j=1;j<=m;j++)
                {
                    cin>>map[i][j];
                }
            }
            int ans=0;
            while(true)
            {
                bool flag=false;
                for(i=1;i<=n;i++)
                {
                    for(j=1;j<=m;j++)
                    {
                        if(map[i][j]=='@'&&!vis[i][j])
                        {
                            //cout<<"find"<<" "<<i<<" "<<j<<endl;
                            flag=true;
                            ans++;
                            dfs(i,j);
                        }
                    }
                }
                if(flag==false)
                break;
            }
            printf("%d\n",ans);
        }
    }
    //
    DFS
  • 相关阅读:
    IOS debug网络PonyDebugger 实践篇
    基于S7-200的PLC对里程轮(增量式码盘)解码的应用
    SICP 习题 (1.14)解题总结
    TQ210裸机编程(2)——LED流水灯
    DP练习(初级):ZigZag
    java 十六进制数的转换
    Oracle DB 执行表空间时间点恢复
    html中文乱码(解决办法)
    html的列表
    MySQL的模糊搜索
  • 原文地址:https://www.cnblogs.com/java20130725/p/3215889.html
Copyright © 2020-2023  润新知