• 字符串系列——uva10361 自动作诗机


    Problem I

    Automatic Poetry

    Input: standard input

    Output: standard output

    Time Limit: 2 seconds

    Memory Limit: 32 MB

     

    “Oh God”, Lara Croft exclaims, “it’s one of these dumb riddles again!”

     

    In Tomb Raider XIV, Lara is, as ever, gunning her way through ancient Egyptian pyramids, prehistoric caves and medival hallways. Now she is standing in front of some important Germanic looking doorway and has to solve a linguistic riddle to pass. As usual, the riddle is not very intellectually challenging.

     

    This time, the riddle involves poems containing a “Schuttelreim”. An example of a Schuttelreim is the following short poem:

     

    Ein Kind halt seinen Schnabel nur,

    wenn es hangt an der Nabelschnur.        

     

    /*German contestants please forgive me. I had to modify something as they were not appearing correctly in plain text format*/

     

    A Schuttelreim seems to be a typical German invention. The funny thing about this strange type of poetry is that if somebody gives you the first line and the beginning of the second one, you can complete the poem yourself. Well, even a computer can do that, and your task is to write a program which completes them automatically. This will help Lara concentrate on the “action” part of Tomb Raider and not on the “intellectual” part.

    Input

    The input will begin with a line containing a single number n. After this line follow n pairs of lines containing Schuttelreims. The first line of each pair will be of the form

    s1<s2>s3<s4>s5

     

    where the si are possibly empty, strings of lowercase characters or blanks. The second line will be a string of lowercase characters or blanks ending with three dots “...”. Lines will we at most 100 characters long.

    Output

    For each pair of Schuttelreim lines l1 and l2 you are to output two lines c1 and c2 in the following way: c1 is the same as l1 only that the bracket marks “<” and “>” are removed. Line c2 is the same as l2 , except that instead of the three dots the string s4s3s2s5 should appear.

    Sample Input

    3

    ein kind haelt seinen <schn>abel <n>ur

    wenn es haengt an der ...

    weil wir zu spaet zur <>oma <k>amen

    verpassten wir das ...

    <d>u <b>ist

    ...

    Sample Output

    ein kind haelt seinen schnabel nur

    wenn es haengt an der nabel schnur

    weil wir zu spaet zur oma kamen

    verpassten wir das koma amen

    du bist

    bu dist


    又是水题。。。

    知道题意后非常容易,一次过。

    一读入就输出,第一行用< >分段录入数组,第二行读到“.”后排序输出。


    代码如下:

    #include<stdio.h>
    #include<string.h>
    
    int main()
    {
        int n, i;
        char ch[4][100], temp;
    
        scanf("%d", &n);
        getchar();
    
        while (n --)
        {
            for (i = 0; i < 4; i ++)
                memset(ch[i], 0, sizeof(ch[i]));
    
            for (i = 0; (temp = getchar()) != '<'; i ++)
                putchar(temp);
            for (i = 0; (temp = getchar()) != '>'; i ++)
            {
                putchar(temp);
                ch[0][i] = temp;
            }
            for (i = 0; (temp = getchar()) != '<'; i ++)
            {
                putchar(temp);
                ch[1][i] = temp;
            }
            for (i = 0; (temp = getchar()) != '>'; i ++)
            {
                putchar(temp);
                ch[2][i] = temp;
            }
            for (i = 0; (temp = getchar()) != '\n'; i ++)
            {
                putchar(temp);
                ch[3][i] = temp;
            }
            putchar('\n');
    
            for (i = 0; (temp = getchar()) != '.'; i ++)
                putchar(temp);
            while ((temp = getchar()) != '\n')
                ;
            printf("%s%s%s%s\n", ch[2], ch[1], ch[0], ch[3]);
        }
        return 0;
    }
    


  • 相关阅读:
    64位内核开发第十二讲,进程监视,ring3跟ring0事件同步.
    64位内核开发第十讲,IRQL中断级别了解
    64位内核开发第九讲,注册表编程.
    64位内核开发第8讲,文件操作.以及删除文件.
    64位内核第七讲.内核中字符串编程注意事项
    【Unity】7.5 移动设备输入
    【Unity】7.4 游戏外设输入
    【Unity】7.3 键盘输入
    【Unity】7.2 鼠标输入
    【Unity】7.1 Input类的方法和变量
  • 原文地址:https://www.cnblogs.com/java20130723/p/3212197.html
Copyright © 2020-2023  润新知