• ZOJ Problem Set


    ZOJ Problem Set - 1061
    Web Navigation

    Time Limit: 2 Seconds                                     Memory Limit: 65536 KB                            

                Standard web browsers contain features to move backward and forward among the  pages recently visited. One way to implement these features is to use two stacks  to keep track of the pages that can be reached by moving backward and forward.  In this problem, you are asked to implement this.

    The following commands need to be supported:

    BACK: Push the current page on the top of the forward stack. Pop the   page from the top of the backward stack, making it the new current page. If the   backward stack is empty, the command is ignored.

    FORWARD: Push the current page on the top of the backward stack. Pop the  page from the top of the forward stack, making it the new current page. If the  forward stack is empty, the command is ignored.

    VISIT <url>: Push the current page on the top of the backward   stack, and make the URL specified the new current page. The forward stack is   emptied.

    QUIT: Quit the browser.

    Assume that the browser initially loads the web page at the URL http://www.acm.org/


    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed   by N input blocks. Each input block is in the format indicated in the problem   description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between   output blocks.


    Input

    Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT,   and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters.   You may assume that no problem instance requires more than 100 elements in each   stack at any time. The end of input is indicated by the QUIT command.

    Output

    For each command other than QUIT, print the URL of the current page after the   command is executed if the command is not ignored. Otherwise, print "Ignored".   The output for each command should be printed on its own line. No output is   produced for the QUIT command.

    Sample Input

    1

    VISIT http://acm.ashland.edu/
      VISIT http://acm.baylor.edu/acmicpc/
      BACK
      BACK
      BACK
      FORWARD
      VISIT http://www.ibm.com/
      BACK
      BACK
      FORWARD
      FORWARD
      FORWARD
      QUIT

    Sample Output

    http://acm.ashland.edu/
      http://acm.baylor.edu/acmicpc/
      http://acm.ashland.edu/
      http://www.acm.org/
      Ignored
      http://acm.ashland.edu/
      http://www.ibm.com/
      http://acm.ashland.edu/
      http://www.acm.org/
      http://acm.ashland.edu/
      http://www.ibm.com/
      Ignored


                                         

    AC代码:

    #include<iostream>
    #include<stdio.h>
    #include<string>
    #include<stack>
    using namespace std;
    void clear(stack<string> &s)
    {
     while(!s.empty())
     {
      s.pop();
     }
    }
    int main()
    {
     int n;
     cin>>n;
     while(n--)
     {
       string cmd,addr,current="http://www.acm.org/";
       stack<string>forward;
       stack<string>backward;
       while(cin>>cmd)
       {
         if(cmd=="QUIT")
           break;
        char ch=getchar();
        if(ch==' ')
        {
         cin>>addr;
         cout<<addr<<endl;
            backward.push(current);
         clear(forward);
         current=addr;
         continue;
        }
        else if(cmd=="BACK")
        {
         if(backward.empty())
         {
          cout<<"Ignored"<<endl;
         }
         else
         {
           forward.push(current);
           current=backward.top();
           backward.pop();
           cout<<current<<endl;
         }
        }
        else if(cmd=="FORWARD")
        {
         if(forward.empty())
         {
          cout<<"Ignored"<<endl;
         }
         else
         {
           backward.push(current);
           current=forward.top();
           forward.pop();
           cout<<current<<endl;
         }
        }
       }
       if(n!=0)cout<<endl;
     }
    }

  • 相关阅读:
    python并发编程之gevent协程(四)
    python并发编程之asyncio协程(三)
    python并发编程之multiprocessing进程(二)
    python并发编程之threading线程(一)
    python设计模式之内置装饰器使用(四)
    python设计模式之装饰器详解(三)
    python设计模式之迭代器与生成器详解(五)
    EF code First数据迁移学习笔记
    15.02.13-代码小技巧
    Route学习笔记之Area的Route注册
  • 原文地址:https://www.cnblogs.com/jackwuyongxing/p/3366520.html
Copyright © 2020-2023  润新知