• ZOJ Problem Set


    ZOJ Problem Set - 1151
    Word Reversal

    Time Limit: 2 Seconds                                     Memory Limit: 65536 KB                            

    For each list of words, output a line with each word reversed without changing   the order of the words.


    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed   by N input blocks. Each input block is in the format indicated in the problem   description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between   output blocks.


    Input

    You will be given a number of test cases. The first line contains a positive   integer indicating the number of cases to follow. Each case is given on a line   containing a list of words separated by one space, and each word contains only   uppercase and lowercase letters.


    Output

    For each test case, print the output on one line.


    Sample Input

    1

    3
      I am happy today
      To be or not to be
      I want to win the practice contest


    Sample Output

    I ma yppah yadot
      oT eb ro ton ot eb
      I tnaw ot niw eht ecitcarp tsetnoc

    AC 代码:

    #include<iostream>
    #include<stdio.h>
    #include<stack>
    using namespace std;
    void display(stack<char> &s)
    {
     while(!s.empty())
     {
      cout<<s.top();
      s.pop();
     }
    }
    int main()
    {
     int n;
     cin>>n;
     while(n--)
     {
      int m;
      stack<char>s;
      cin>>m;
      getchar();
      while(1)
      {
       char t=getchar();
       //cout<<"t: "<<t<<endl;
       if(t==' ')
       {
        display(s);
        m--;
        cout<<endl;
        if(m==0)break;
       }
       else if(t==' ')
       {
          display(s);
        cout<<' '; 
       }
       else s.push(t);
      }
      if(n!=0)cout<<endl;
     }
    }

  • 相关阅读:
    查看MySQL数据库表的命令介绍
    MySQL 数据库常用命令 超级实用版分享
    从cmd中进入MySQL的命令界面
    POJ-1664 放苹果
    ant常用命令
    ant来历
    ant
    ant有什么用
    ANT的安装和配置(windows)
    Experimental Educational Round: VolBIT Formulas Blitz B
  • 原文地址:https://www.cnblogs.com/jackwuyongxing/p/3366519.html
Copyright © 2020-2023  润新知