• Hangover


    Hangover
    Time Limit: 1000MS Memory Limit: 10000K
    Total Submissions: 48443 Accepted: 22764

    Description

    How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



    Input

    The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

    Output

    For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

    Sample Input

    1.00
    3.71
    0.04
    5.19
    0.00

    Sample Output

    3 card(s)
    61 card(s)
    1 card(s)
    273 card(s)


    这个题总体来说十分简单,下面是源代码:
    //Hangover
    //Time Limit: 1000MS Memory Limit: 10000K

    #include<stdio.h>

    int main()
    {
    float a;
    int i;
    float b=0;
    while(scanf("%f",&a))
    {
    if(a<0.01){ printf("这个数太小了/n");
    continue;}
    else if(a>5.20){ printf("这个数太大了/n");
    continue;}
    else
    { b=0;
    for(i=2;;i++)
    {
    b=b+(float)1/(float)i;
    if (b>a)
    {
    printf("%d card(s)/n",i-1);
    break;
    }
    }
    }

    }

    }

    刚开始没有写else下b=0;这句话,认为每次计算结束后b会重新复制,观察才发现,程序一直没有退出while循环,所以b的值是保存着的,所以为了
    结果的每次都正确需要每次都给b清零!!
  • 相关阅读:
    第二次冲刺 站立会议7
    第二次冲刺 站立会议6
    第二次冲刺 站立会议5
    第二次冲刺 站立会议4
    第二次冲刺 站立会议3
    第二次冲刺 站立会议2
    第二次冲刺 站立会议1
    第一次冲刺 站立会议9
    第一次冲刺 站立会议8
    第一次冲刺 站立会议7
  • 原文地址:https://www.cnblogs.com/jackhub/p/3147253.html
Copyright © 2020-2023  润新知