• POJ 1330 Nearest Common Ancestors (Tarjan & LCA)


    Nearest Common Ancestors
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 13981   Accepted: 7454

    Description

    A rooted tree is a well-known data structure in computer science and engineering. An example is shown below: 

     
    In the figure, each node is labeled with an integer from {1, 2,...,16}. Node 8 is the root of the tree. Node x is an ancestor of node y if node x is in the path between the root and node y. For example, node 4 is an ancestor of node 16. Node 10 is also an ancestor of node 16. As a matter of fact, nodes 8, 4, 10, and 16 are the ancestors of node 16. Remember that a node is an ancestor of itself. Nodes 8, 4, 6, and 7 are the ancestors of node 7. A node x is called a common ancestor of two different nodes y and z if node x is an ancestor of node y and an ancestor of node z. Thus, nodes 8 and 4 are the common ancestors of nodes 16 and 7. A node x is called the nearest common ancestor of nodes y and z if x is a common ancestor of y and z and nearest to y and z among their common ancestors. Hence, the nearest common ancestor of nodes 16 and 7 is node 4. Node 4 is nearer to nodes 16 and 7 than node 8 is. 

    For other examples, the nearest common ancestor of nodes 2 and 3 is node 10, the nearest common ancestor of nodes 6 and 13 is node 8, and the nearest common ancestor of nodes 4 and 12 is node 4. In the last example, if y is an ancestor of z, then the nearest common ancestor of y and z is y. 

    Write a program that finds the nearest common ancestor of two distinct nodes in a tree. 

    Input

    The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case starts with a line containing an integer N , the number of nodes in a tree, 2<=N<=10,000. The nodes are labeled with integers 1, 2,..., N. Each of the next N -1 lines contains a pair of integers that represent an edge --the first integer is the parent node of the second integer. Note that a tree with N nodes has exactly N - 1 edges. The last line of each test case contains two distinct integers whose nearest common ancestor is to be computed.

    Output

    Print exactly one line for each test case. The line should contain the integer that is the nearest common ancestor.

    Sample Input

    2
    16
    1 14
    8 5
    10 16
    5 9
    4 6
    8 4
    4 10
    1 13
    6 15
    10 11
    6 7
    10 2
    16 3
    8 1
    16 12
    16 7
    5
    2 3
    3 4
    3 1
    1 5
    3 5
    

    Sample Output

    4
    3
    
    

    Source

     
     
    算法详解见: http://dongxicheng.org/structure/lca-rmq/
     
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    
    using namespace std;
    
    const int N=10010;
    
    struct Edge{
        int v,nxt;
    }edge[N];
    
    int head[N],indeg[N],father[N],vis[N];
    int n,ans,cnt,flag,A,B;
    
    void addedge(int cu,int cv){
        edge[cnt].v=cv;
        edge[cnt].nxt=head[cu];
        head[cu]=cnt++;
    }
    
    int findSet(int x){
        if(x!=father[x]){
            father[x]=findSet(father[x]);
        }
        return father[x];
    }
    
    void Tarjan(int u){
        father[u]=u;
        vis[u]=1;
        for(int i=head[u];i!=-1 && !flag;i=edge[i].nxt){
            int v=edge[i].v;
            if(!vis[v]){
                Tarjan(v);
                father[v]=u;
            }
        }
        if(u==A && vis[B]){
            ans=findSet(B);
            flag=1;
        }else if(u==B && vis[A]){
            ans=findSet(A);
            flag=1;
        }
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t;
        scanf("%d",&t);
        while(t--){
            cnt=0;
            memset(head,-1,sizeof(head));
            memset(indeg,0,sizeof(indeg));
            memset(vis,0,sizeof(vis));
            flag=0;
            scanf("%d",&n);
            int u,v;
            for(int i=0;i<n-1;i++){
                scanf("%d%d",&u,&v);
                addedge(u,v);
                indeg[v]++;
            }
            scanf("%d%d",&A,&B);
            for(int i=1;i<=n;i++)
                if(indeg[i]==0){
                    Tarjan(i);
                    break;
                }
            printf("%d\n",ans);
        }
        return 0;
    }
  • 相关阅读:
    多校省选模拟33 C
    省选测试47 T2宝石(P5401 [CTS2019]珍珠) 题解
    省选测试39
    省选测试38
    省选测试37
    自嗨测试赛4
    自嗨测试赛3
    自嗨测试赛2
    自嗨测试赛1
    树状数组 学习笔记
  • 原文地址:https://www.cnblogs.com/jackge/p/3071217.html
Copyright © 2020-2023  润新知