• POJ 1201 Intervals


    Intervals
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 18740   Accepted: 7042

    Description

    You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 
    Write a program that: 
    reads the number of intervals, their end points and integers c1, ..., cn from the standard input, 
    computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, 
    writes the answer to the standard output. 

    Input

    The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

    Output

    The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

    Sample Input

    5
    3 7 3
    8 10 3
    6 8 1
    1 3 1
    10 11 1

    Sample Output

    6

    Source

     
     
    #include <stdio.h>
    #include <string.h>
    #define EM 300000
    #define VM 50005
    
    struct edge
    {
        int v,w,next;
    }e[EM];
    int head[VM],ep;
    
    void addedge(int cu,int cv,int cw)
    {
        ep ++;
        e[ep].v = cv;
        e[ep].w = cw;
        e[ep].next = head[cu];
        head[cu] = ep;
    }
    int maxn (int a,int b)
    {
        return a > b?a:b;
    }
    
    void spfa (int n)
    {
        int vis[VM],dis[VM],stack[EM];
        memset (vis,0,sizeof(vis));
        memset (dis,-1,sizeof(dis));
        //for (int i = 0;i <= n;i ++)
         //   dis[i] = inf;
        dis[n+2] = 0;
        int top = 1;
        vis[n+2] = 1;
        stack[0] = n+2;
        while (top)
        {
            int u = stack[--top];
            vis[u] = 0;
            for (int i = head[u];i != -1;i = e[i].next)
            {
                int v = e[i].v;
                if (dis[v] < dis[u] + e[i].w)
                {
                    dis[v] = dis[u] + e[i].w;
                    if (!vis[v])
                    {
                        vis[v] = 1;
                        stack[top++] = v;
                    }
                }
            }
        }
        printf ("%d\n",dis[n]);
    }
    int main ()
    {
        int n,v1,v2,m,cost;
        ep = 0;
        scanf ("%d",&n);
        m = n;
        memset (head,-1,sizeof(head));
        int max = -1;
        while (m --)
        {
            scanf ("%d%d%d",&v1,&v2,&cost);
            addedge (v1,v2+1,cost);
            max = maxn (max,v2+1);
        }
        for (int i = 0;i < max;i ++)
        {
            addedge (i,i+1,0);
            addedge (i+1,i,-1);
            addedge (max+2,i,0);
        }
        spfa (max);
        return 0;
    }
  • 相关阅读:
    [python] defaultdict
    [VM workstation]VM workstation 中的虚拟机连不上网络
    [Docker] docker 基础学习笔记1(共6篇)
    [python] import curses
    servlet 产生随机验证码
    JSTL标签库 sql标签
    JSTLLearning
    Ajax实现联想(建议)功能
    HDU 1241
    Servlet实现文件上传
  • 原文地址:https://www.cnblogs.com/jackge/p/3062028.html
Copyright © 2020-2023  润新知