• POJ 3013 Big Christmas Tree (SPFA)


    Big Christmas Tree
    Time Limit: 3000MS   Memory Limit: 131072K
    Total Submissions: 18303   Accepted: 3881

    Description

    Christmas is coming to KCM city. Suby the loyal civilian in KCM city is preparing a big neat Christmas tree. The simple structure of the tree is shown in right picture.

    The tree can be represented as a collection of numbered nodes and some edges. The nodes are numbered 1 through n. The root is always numbered 1. Every node in the tree has its weight. The weights can be different from each other. Also the shape of every available edge between two nodes is different, so the unit price of each edge is different. Because of a technical difficulty, price of an edge will be (sum of weights of all descendant nodes) × (unit price of the edge).

    Suby wants to minimize the cost of whole tree among all possible choices. Also he wants to use all nodes because he wants a large tree. So he decided to ask you for helping solve this task by find the minimum cost.

    Input

    The input consists of T test cases. The number of test cases T is given in the first line of the input file. Each test case consists of several lines. Two numbers ve (0 ≤ ve ≤ 50000) are given in the first line of each test case. On the next line, v positive integers wi indicating the weights of v nodes are given in one line. On the following e lines, each line contain three positive integers abc indicating the edge which is able to connect two nodes a and b, and unit price c.

    All numbers in input are less than 216.

    Output

    For each test case, output an integer indicating the minimum possible cost for the tree in one line. If there is no way to build a Christmas tree, print “No Answer” in one line.

    Sample Input

    2
    2 1
    1 1
    1 2 15
    7 7
    200 10 20 30 40 50 60
    1 2 1
    2 3 3
    2 4 2
    3 5 4
    3 7 2
    3 6 3
    1 5 9

    Sample Output

    15
    1210

    Source

    POJ Monthly--2006.09.29, Kim, Chan Min (kcm1700@POJ)
     
     
    题意:要建一棵圣诞树,使得总的花费最小。具体规则是:圣诞树是一颗无向树形图,其中,编号为1的节点为根节点,原始图中每条边具有边权(unit):材料的单位价值,每个点也有一个权(weight):点的重量。总的花费则是生成树中所有点的花费之和。 而每个点的花费为 根结点到该点的距离(边权unit)* 该点的重量。

    思路:求出各点的最短路径 再与点的重量相乘之和; 注意两点我觉得,inf 要定义足够大,10个9吧,还有,用memset 初始化会严重超时,不用竟然才600多MS 。。。
     
    #include<iostream>
    #include<queue>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int VM=50010;
    const int EM=50010;
    const long long INF=9999999999;
    
    int n,m,cnt,weight[VM];
    int head[VM],vis[VM];
    long long dis[VM];
    
    struct Edge{
        int to,nxt;
        long long cap;
    }edge[EM<<1];
    
    void addedge(int cu,int cv,long long cw){
        edge[cnt].to=cv;
        edge[cnt].cap=cw;
        edge[cnt].nxt=head[cu];
        head[cu]=cnt++;
    }
    
    long long SPFA(){
        queue<int> q;
        while(!q.empty())
            q.pop();
        for(int i=1;i<=n;i++){
            dis[i]=INF;
            vis[i]=0;
        }
        dis[1]=0;
        vis[1]=1;
        q.push(1);
        while(!q.empty()){
            int u=q.front();
            q.pop();
            vis[u]=0;
            for(int i=head[u];i!=-1;i=edge[i].nxt){
                int v=edge[i].to;
                if(dis[v]>dis[u]+edge[i].cap){
                    dis[v]=dis[u]+edge[i].cap;
                    if(!vis[v]){
                        vis[v]=1;
                        q.push(v);
                    }
                }
            }
        }
        long long ans=0;
        for(int i=1;i<=n;i++){
            if(dis[i]==INF)
                return 0;
            ans+=weight[i]*dis[i];
        }
        return ans;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t;
        scanf("%d",&t);
        while(t--){
            cnt=0;
            memset(head,-1,sizeof(head));
            scanf("%d%d",&n,&m);
            for(int i=1;i<=n;i++)
                scanf("%d",&weight[i]);
            int u,v;
            long long w;
            while(m--){
                scanf("%d%d%I64d",&u,&v,&w);
                addedge(u,v,w);
                addedge(v,u,w);
            }
            if(n==0 || n==1){
                printf("0\n");
                continue;
            }
            long long ans=SPFA();
            if(ans==0)
                printf("No Answer\n");
            else
                printf("%I64d\n",ans);
        }
        return 0;
    }
     
     

    dij+heap:

    #include <stdio.h>
    #include <string.h>
    #include <queue>
    #define M 50010
    using namespace std;
    
    __int64 inf,dist[M];
    int head[M],cost[M],e;
    bool vis[M];
    struct E
    {
        int v,w,nxt;
    } edge[2*M];
    
    struct data
    {
        int u;
        __int64 w;
        bool operator < (const data &a) const
        {
            return a.w < w;
        }
    };
    
    void addedge (int cu,int cv,int cw)
    {
        edge[e].v = cv;
        edge[e].w = cw;
        edge[e].nxt = head[cu];
        head[cu] = e ++;
    }
    
    __int64 dij (int n)
    {
        memset (vis,false,sizeof(vis));
        memset (dist,0x3f,sizeof(dist));
        memset (&inf,0x3f,sizeof(__int64));
        dist[1] = 0;
        priority_queue <data> que;
        data cur;
        cur.u = 1,cur.w = 0;
        que.push(cur);
        while (!que.empty())
        {
            cur = que.top();
            que.pop();
            int u = cur.u;
            if (vis[u])
                continue;
            vis[u] = true;
            for (int i = head[u]; i != -1; i = edge[i].nxt)
            {
                int v = edge[i].v;
                if (!vis[v] && dist[v] > dist[u] + edge[i].w)
                {
                    dist[v] = dist[u] + edge[i].w;
                    cur.u = v;
                    cur.w = dist[v];
                    que.push(cur);
                }
            }
        }
        __int64 res = 0;
        for (int i = 2; i <= n; i ++)
        {
            if (dist[i] == inf)
                return 0;
            res += dist[i]*cost[i];
        }
        return res;
    }
    int main ()
    {
        int n,m,u,v,w,i,T;
        scanf ("%d",&T);
        while (T --)
        {
            memset (head,0xFF,sizeof(head));
            e = 0;
            scanf ("%d%d",&n,&m);
            for (i = 1; i <= n; i ++)
                scanf ("%d",&cost[i]);
            while (m --)
            {
                scanf ("%d%d%d",&u,&v,&w);
                addedge (u,v,w);
                addedge (v,u,w);
            }
            if (n == 0||n == 1)
                printf ("0\n");
            else
            {
                __int64 ans = dij (n);
                if (!ans)
                    printf ("No Answer\n");
                else
                    printf ("%I64d\n",ans);
            }
        }
        return 0;
    }
  • 相关阅读:
    使用postman模拟上传文件到springMVC的坑:the request was rejected because no multipart boundary was found
    win10 安装多个版本的jdk,如何切换
    String类的substring方法
    tomcat7.0配置CORS(跨域资源共享)
    win7下安装centos6.5后,开机无法进入选择双系统启动界面,只能启动centos的解决办法
    java位运算
    JDK源码--ArrayList浅析
    使用Jasperreporter生成入库出库单打印等报表操作
    centos6.5下安装zip格式的tomcat7和tomcat8,并同时运行
    Centos7配置文件共享服务器SAMBA三步曲(转)
  • 原文地址:https://www.cnblogs.com/jackge/p/3053438.html
Copyright © 2020-2023  润新知