• POJ 2244 Eeny Meeny Moo (约瑟夫环问题)


    Eeny Meeny Moo
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 2929   Accepted: 2015

    Description

    Surely you have made the experience that when too many people use the Internet simultaneously, the net becomes very, very slow. 
    To put an end to this problem, the University of Ulm has developed a contingency scheme for times of peak load to cut off net access for some cities of the country in a systematic, totally fair manner. Germany's cities were enumerated randomly from 1 to n. Freiburg was number 1, Ulm was number 2, Karlsruhe was number 3, and so on in a purely random order. 
    Then a number m would be picked at random, and Internet access would first be cut off in city 1 (clearly the fairest starting point) and then in every mth city after that, wrapping around to 1 after n, and ignoring cities already cut off. For example, if n=17 and m=5, net access would be cut off to the cities in the order [1,6,11,16,5,12,2,9,17,10,4,15,14,3,8,13,7]. The problem is that it is clearly fairest to cut off Ulm last (after all, this is where the best programmers come from), so for a given n, the random number m needs to be carefully chosen so that city 2 is the last city selected. 

    Your job is to write a program that will read in a number of cities n and then determine the smallest integer m that will ensure that Ulm can surf the net while the rest of the country is cut off.

    Input

    The input will contain one or more lines, each line containing one integer n with 3 <= n < 150, representing the number of cities in the country. 
    Input is terminated by a value of zero (0) for n.

    Output

    For each line of the input, print one line containing the integer m fulfilling the requirement specified above.

    Sample Input

    3
    4
    5
    6
    7
    8
    9
    10
    11
    12
    0
    

    Sample Output

    2
    5
    2
    4
    3
    11
    2
    3
    8
    16
    

    Source

     
    题意:N个城市轮流断电,先把城市1断掉,之后便剩下n-1个城市,在这种情况下,求最小的M使胜者为最初的城市2 (换句话说就是现在的城市1)。现在将问题转化一下:在 1...n-1 个数中,求最小的数m,使得胜者为1。
    算法:数学递推
    参考http://www.cppblog.com/AClayton/archive/2007/11/06/35964.html
     
    #include<stdio.h>
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int n;
        while(~scanf("%d",&n) && n){
            int m,s;
            for(m=1;;m++){
                s=0;
                for(int i=2;i<n;i++)
                    s=(s+m)%i;
                if(s==0){
                    printf("%d\n",m);
                    break;
                }
            }
        }
        return 0;
    }
  • 相关阅读:
    关于测试准备工作的要求--测试用例
    测试用例设计:PICT的安装及使用
    导师应该做什么
    黑盒测试流程
    工作职责及内容
    自己在项目中写的一个Jquery插件和Jquery tab 功能
    Javascript中的" "
    Jquery.ajax 详细解释 通过Http请求加载远程数据
    Jquery中的toggle()方法
    Umbraco examine search media folder 中的pdf文件
  • 原文地址:https://www.cnblogs.com/jackge/p/3052066.html
Copyright © 2020-2023  润新知