• POJ 2828 Buy Tickets (线段树)


    Buy Tickets
    Time Limit: 4000MS   Memory Limit: 65536K
    Total Submissions: 9712   Accepted: 4679

    Description

    Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

    The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

    It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

    People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

    Input

    There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

    • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
    • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

    There no blank lines between test cases. Proceed to the end of input.

    Output

    For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

    Sample Input

    4
    0 77
    1 51
    1 33
    2 69
    4
    0 20523
    1 19243
    1 3890
    0 31492

    Sample Output

    77 33 69 51
    31492 20523 3890 19243

    Hint

    The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.

    Source

    思路:从后往前插,pos表示他前面有多少的空位,叶子结点存他的val 这样就转化到线段树上 然后就简单了

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    #define L(rt) (rt<<1)
    #define R(rt) (rt<<1|1)
    
    const int N=200010;
    
    int loc[N],cnt;
    
    struct node{
        int l,r;
        int val,pos;    //pos表示当点有多少空位
    }tree[N*3];
    
    struct data{
        int pos,num;
    }pep[N];
    
    void build(int l,int r,int rt){
        tree[rt].l=l;
        tree[rt].r=r;
        if(l==r){
            tree[rt].pos=1;
            return ;
        }
        int mid=(l+r)>>1;
        build(l,mid,L(rt));
        build(mid+1,r,R(rt));
        tree[rt].pos=tree[L(rt)].pos+tree[R(rt)].pos;
    }
    
    void update(int val,int pos,int rt){
        if(tree[rt].l==tree[rt].r){
            tree[rt].val=val;
            tree[rt].pos=0;
            return ;
        }
        if(tree[L(rt)].pos>pos)
            update(val,pos,L(rt));
        else
            update(val,pos-tree[L(rt)].pos,R(rt));
        tree[rt].pos=tree[L(rt)].pos+tree[R(rt)].pos;
    }
    
    void query(int rt){
        if(tree[rt].l==tree[rt].r){
            loc[cnt++]=tree[rt].val;
            return ;
        }
        query(L(rt));
        query(R(rt));
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int n;
        while(~scanf("%d",&n)){
            cnt=0;
            for(int i=0;i<n;i++)
                scanf("%d%d",&pep[i].pos,&pep[i].num);
            build(1,n,1);
            for(int i=n-1;i>=0;i--)
                update(pep[i].num,pep[i].pos,1);
            query(1);
            for(int i=0;i<n-1;i++)
                printf("%d ",loc[i]);
            printf("%d\n",loc[n-1]);
        }
        return 0;
    }
  • 相关阅读:
    linux RCU锁机制分析
    什么是上下文切换
    Linux内核哈希表分析与应用
    linux内核中hlist_head和hlist_node结构解析
    如何使用queue_delayed_work函数
    《Linux内核设计与实现》读书笔记(十)- 内核同步方法
    自旋锁,读写锁和顺序锁的实现原理
    C语言中内存分布及程序运行中(BSS段、数据段、代码段、堆栈)
    深入理解linux系统下proc文件系统内容
    以太网最小帧长为什么是64字节
  • 原文地址:https://www.cnblogs.com/jackge/p/3039476.html
Copyright © 2020-2023  润新知