• POJ 3259 Wormholes (Bellman)


    Wormholes
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 23270   Accepted: 8301

    Description

    While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

    As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

    To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

    Input

    Line 1: A single integer, FF farm descriptions follow. 
    Line 1 of each farm: Three space-separated integers respectively: NM, and W 
    Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
    Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

    Output

    Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

    Sample Input

    2
    3 3 1
    1 2 2
    1 3 4
    2 3 1
    3 1 3
    3 2 1
    1 2 3
    2 3 4
    3 1 8

    Sample Output

    NO
    YES

    Hint

    For farm 1, FJ cannot travel back in time. 
    For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

    Source

     
     
    题意:John的农场里field块地,path条路连接两块地,hole个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。我们的任务是知道会不会在从某块地出发后又回来,看到了离开之前的自己。

    思路:用bellman-ford 判断有没有负权回路,如果有他就能看到自己。 不过,我认为应该判断每个点有没有负权回路,而不仅仅只判断第一个点就行了(如果某位大牛路过看到,觉得理解不对 希望多多指教)
     
     http://www.cnblogs.com/Jason-Damon/archive/2012/04/21/2460850.html
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int VM=520;
    const int EM=2520;
    const int INF=0x3f3f3f3f;
    
    struct Edge{
        int u,v;
        int cap;
    }edge[EM<<1];
    
    int n,m,k;
    int cnt,dis[VM];
    
    void addedge(int cu,int cv,int cw){
        edge[cnt].u=cu;     edge[cnt].v=cv;     edge[cnt].cap=cw;
        cnt++;
    }
    
    int Bellman_ford(){
        for(int i=1;i<=n;i++)
            dis[i]=INF;
        dis[1]=0;
        for(int i=1;i<n;i++)    //n-1次松弛
            for(int j=0;j<cnt;j++)  //枚举每条边
                if(dis[edge[j].v]>dis[edge[j].u]+edge[j].cap)
                    dis[edge[j].v]=dis[edge[j].u]+edge[j].cap;
        for(int j=0;j<cnt;j++)
            if(dis[edge[j].v]>dis[edge[j].u]+edge[j].cap)   //判断是否存在负权边
                return 0;
        return 1;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t;
        scanf("%d",&t);
        while(t--){
            scanf("%d%d%d",&n,&m,&k);
            cnt=0;
            int u,v,w;
            while(m--){
                scanf("%d%d%d",&u,&v,&w);
                addedge(u,v,w);
                addedge(v,u,w);
            }
            while(k--){
                scanf("%d%d%d",&u,&v,&w);
                addedge(u,v,-w);
            }
            int ans=Bellman_ford();
            printf("%s\n",ans==0?"YES":"NO");
        }
        return 0;
    }

     下面这个代码稍快一点:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int VM=520;
    const int EM=2520;
    const int INF=0x3f3f3f3f;
    
    struct node{
        int u,v;
        int cap;
    }edge[EM<<1];
    
    int n,m,k;
    int cnt,dis[VM];
    
    void addedge(int cu,int cv,int cw){
        edge[cnt].u=cu;     edge[cnt].v=cv;     edge[cnt].cap=cw;
        cnt++;
    }
    
    int Bellman_ford(){
        int i,j;
        for(i=1;i<=n;i++)
            dis[i]=INF;
        dis[1]=0;
        for(i=1;i<=n;i++){
            int flag=0;
            for(j=0;j<cnt;j++)
                if(dis[edge[j].v]>dis[edge[j].u]+edge[j].cap){
                    dis[edge[j].v]=dis[edge[j].u]+edge[j].cap;
                    flag=1;
                }   
            if(!flag)    //优化
                break;
        }
        return i==n+1;  //相等则存在正环
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int t;
        scanf("%d",&t);
        while(t--){
            scanf("%d%d%d",&n,&m,&k);
            cnt=0;
            int u,v,w;
            while(m--){
                scanf("%d%d%d",&u,&v,&w);
                addedge(u,v,w);
                addedge(v,u,w);
            }
            while(k--){
                scanf("%d%d%d",&u,&v,&w);
                addedge(u,v,-w);
            }
            int ans=Bellman_ford();
            printf("%s\n",ans==1?"YES":"NO");
        }
        return 0;
    }
  • 相关阅读:
    [BUUOJ记录] [强网杯 2019]随便注(三种方法)
    Content Security Policy (CSP)内容安全策略总结
    [HGAME Week2] Cosmos的博客后台
    [BUUOJ记录] [ACTF2020 新生赛]Include
    PHP弱类型hash比较缺陷
    CTF常见源码泄漏总结
    Sqlmap Tamper绕过脚本详解
    Golden Pyramid
    Prime Palindrome Golf
    Min and Max
  • 原文地址:https://www.cnblogs.com/jackge/p/3038494.html
Copyright © 2020-2023  润新知