• POJ 2240 Arbitrage (Floyd)


    Arbitrage
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 12287   Accepted: 5168

    Description

    Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

    Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

    Input

    The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
    Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

    Output

    For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

    Sample Input

    3
    USDollar
    BritishPound
    FrenchFranc
    3
    USDollar 0.5 BritishPound
    BritishPound 10.0 FrenchFranc
    FrenchFranc 0.21 USDollar
    
    3
    USDollar
    BritishPound
    FrenchFranc
    6
    USDollar 0.5 BritishPound
    USDollar 4.9 FrenchFranc
    BritishPound 10.0 FrenchFranc
    BritishPound 1.99 USDollar
    FrenchFranc 0.09 BritishPound
    FrenchFranc 0.19 USDollar
    
    0
    

    Sample Output

    Case 1: Yes
    Case 2: No
    

    Source

    题意:汇率增值问题,给出几对货币之间的汇率,计算是否存在一种兑换方法,可以使货币升值(也就是汇率大于1)。

    思路:第一道自己用floyd 做出来的题,虽然还是有些不太了解
    只要rate[i][i] 大于1,那就能通过兑换的方法赢利。 floyd的应用,
    if (rate[i][j] < rate[i][k]*rate[k][j])
     rate[i][j] = rate[i][k]*rate[k][j];

    #include<iostream>
    #include<cstdio>
    #include<map>
    #include<cstring>
    #include<string>
    
    using namespace std;
    
    const int INF=0x3f3f3f3f;
    const int N=40;
    
    int n,m;
    double g[N][N];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int cases=0;
        map<string,int> mp;
        int cnt;
        char s1[100],s2[100];
        while(~scanf("%d",&n) && n){
            mp.clear();
            memset(g,0,sizeof(g));
            int i,j,k;
            cnt=0;
            for(i=0;i<n;i++){
                scanf("%s",s1);
                if(!mp[s1])
                    mp[s1]=++cnt;
            }
            scanf("%d",&m);
            double p;
            for(i=0;i<m;i++){
                scanf("%s%lf%s",s1,&p,s2);
                g[mp[s1]][mp[s2]]=p;
            }
            for(k=1;k<=n;k++)
                for(i=1;i<=n;i++)
                    for(j=1;j<=n;j++)
                        if(g[i][j]<g[i][k]*g[k][j])
                            g[i][j]=g[i][k]*g[k][j];
            if(g[1][1]>1)
                printf("Case %d: Yes\n",++cases);
            else
                printf("Case %d: No\n",++cases);
        }
        return 0;
    }
  • 相关阅读:
    python——简单tcp
    关于app签名——无法对 jar 进行签名: 时间戳颁发机构没有响应
    ionic 创建证书
    Android SDK proxy server
    ionic2-生成error
    ng2项目报错
    关于ckeditor粘贴图片自动上传
    简单分页效果
    linux好用的命令
    linux给用户添加sudo权限
  • 原文地址:https://www.cnblogs.com/jackge/p/3037931.html
Copyright © 2020-2023  润新知