• HDU AreYouBusy (经典混合背包)


    AreYouBusy

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
    Total Submission(s) : 1   Accepted Submission(s) : 1
    Problem Description
    Happy New Term! As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad. What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)?
     
    Input
    There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.
     
    Output
    One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .
     
    Sample Input
    3 3 2 1 2 5 3 8 2 0 1 0 2 1 3 2 4 3 2 1 1 1
    3 4 2 1 2 5 3 8 2 0 1 1 2 8 3 2 4 4 2 1 1 1
    1 1 1 0 2 1
    5 3 2 0 1 0 2 1 2 0 2 2 1 1 2 0 3 2 2 1 2 1 1 5 2 8 3 2 3 8 4 9 5 10
     
    Sample Output
    5 13 -1 -1
     
    Author
    hphp
     
    Source
    2010 ACM-ICPC Multi-University Training Contest(10)——Host by HEU
     
     

     经典混合背包

         题目给了很多类别的物品。用 数组dp[i][j],表示第i组,时间为j时的快乐值。每得到一组工作就进行一次DP,所以dp[i]为第i组的结果。

     

      第一类,至少选一项,即必须要选,那么在开始时,对于这一组的dp的初值,应该全部赋为负无穷,这样才能保证不会出现都不选的情况。

    状态转移方程:

    dp[i][j]=max(dp[i][j],max(dp[i][j-w[x]]+p[x],dp[i-1][j-w[x]]+p[x]));

     

    dp[i][j]: 是不选择当前工作;

    dp[i-1][j-w[x]]+p[x]: 第一次在本组中选物品,由于开始将该组dp赋为了负无穷,所以第一次取时,必须由上一组的结果推知,这样才能保证得到全局最优解;

    dp[i][j-w[x]]+p[x]:表示选择当前工作,并且不是第一次取;

     

      第二类,最多选一项,即要么不选,一旦选,只能是第一次选。

    状态转移方程:

    dp[i][j]=max(dp[i][j],dp[i-1][j-w[x]]+p[x]);

    由于要保证得到全局最优解,所以在该组DP开始以前,应该将上一组的DP结果先复制到这一组的dp[i]数组里,因为当前组的数据是在上一组数据的基础上进行更新的。

     

         第三类,任意选,即不论选不选,选几个都可以。

    状态转移方程为:

    dp[i][j]=max(dp[i][j],dp[i][j-w[x]]+p[x]);

    同样要保证为得到全局最优解,先复制上一组解,数据在当前组更新。

     

     

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    
    using namespace std;
    
    const int INF=0x3f3f3f3f;
    
    int n,m,sum;
    int w[110],p[110];
    int dp[110][110];
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d%d",&n,&sum)){
            memset(dp,0,sizeof(dp));
            int i,j,k,g;
            for(i=1;i<=n;i++){
                scanf("%d%d",&m,&g);
                for(k=1;k<=m;k++)
                    scanf("%d%d",&w[k],&p[k]);
                if(g==0){
                    for(j=0;j<=sum;j++) //当前组初始化
                        dp[i][j]=-INF;
                    for(k=1;k<=m;k++)
                        for(j=sum;j>=w[k];j--)
                            dp[i][j]=max(dp[i][j],max(dp[i][j-w[k]]+p[k],dp[i-1][j-w[k]]+p[k]));
                }else if(g==1){
                    for(j=0;j<=sum;j++) //当前组初始化
                        dp[i][j]=dp[i-1][j];
                    for(k=1;k<=m;k++)
                        for(j=sum;j>=w[k];j--)
                            dp[i][j]=max(dp[i][j],dp[i-1][j-w[k]]+p[k]);
                }else if(g==2){
                    for(j=0;j<=sum;j++) //当前组初始化
                        dp[i][j]=dp[i-1][j];
                    for(k=1;k<=m;k++)
                        for(j=sum;j>=w[k];j--)
                            dp[i][j]=max(dp[i][j],dp[i][j-w[k]]+p[k]);
                }
            }
            dp[n][sum]=max(dp[n][sum],-1);  //没有完成任务的值都为负的,做输出调整,输出-1
            printf("%d\n",dp[n][sum]);
        }
        return 0;
    }

    滚动数组:

    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    #define INF 1<<29
    int n, m, sum, g;
    int w[101],p[101];
    int dp[101],tmp[101];
    int main()
    {
        int i, j, x;
        while(~scanf("%d%d",&n,&sum))
        {
            memset(dp,0,sizeof(dp));
            for(i=1;i<=n;i++)
            {
                scanf("%d%d",&m,&g);
                for(x=1;x<=m;x++)
                    scanf("%d%d",&w[x],&p[x]);
                if(g==0)
                {
                    for(j=0;j<=sum;j++)
                    {
                        tmp[j]=dp[j];
                        dp[j]=-INF;
                    }
                    for(x=1;x<=m;x++)
                        for(j=sum;j>=w[x];j--)
                            dp[j]=max(dp[j],max(dp[j-w[x]]+p[x],tmp[j-w[x]]+p[x]));
                }
                else if(g==1)
                {
                    for(j=0;j<=sum;j++) //当前组初始化
                        tmp[j]=dp[j];
                    for(x=1;x<=m;x++)
                        for(j=sum;j>=w[x];j--)
                                dp[j]=max(dp[j],tmp[j-w[x]]+p[x]);
                }
                else if(g==2)
                {
                    for(j=0;j<=sum;j++) //当前组初始化
                        tmp[j]=dp[j];
                    for(x=1;x<=m;x++)
                        for(j=sum;j>=w[x];j--)
                            dp[j]=max(dp[j],dp[j-w[x]]+p[x]);
                }
    
            }
            dp[sum]=max(dp[sum],-1); //没有完成任务的值都为负的,做输出调整,输出-1
            printf("%d\n",dp[sum]);
        }
        return 0;
    }
  • 相关阅读:
    LeetCode OJ 107. Binary Tree Level Order Traversal II
    LeetCode OJ 116. Populating Next Right Pointers in Each Node
    LeetCode OJ 108. Convert Sorted Array to Binary Search Tree
    LeetCode OJ 105. Construct Binary Tree from Preorder and Inorder Traversal
    LeetCode OJ 98. Validate Binary Search Tree
    老程序员解Bug的通用套路
    转载 四年努力,梦归阿里,和大家聊聊成长感悟
    转载面试感悟----一名3年工作经验的程序员应该具备的技能
    Web Service和Servlet的区别
    关于spring xml文件中的xmlns,xsi:schemaLocation
  • 原文地址:https://www.cnblogs.com/jackge/p/3036374.html
Copyright © 2020-2023  润新知