• POJ 1125 Stockbroker Grapevine


    Stockbroker Grapevine
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 22649   Accepted: 12348

    Description

    Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way. 

    Unfortunately for you, stockbrokers only trust information coming from their "Trusted sources" This means you have to take into account the structure of their contacts when starting a rumour. It takes a certain amount of time for a specific stockbroker to pass the rumour on to each of his colleagues. Your task will be to write a program that tells you which stockbroker to choose as your starting point for the rumour, as well as the time it will take for the rumour to spread throughout the stockbroker community. This duration is measured as the time needed for the last person to receive the information.

    Input

    Your program will input data for different sets of stockbrokers. Each set starts with a line with the number of stockbrokers. Following this is a line for each stockbroker which contains the number of people who they have contact with, who these people are, and the time taken for them to pass the message to each person. The format of each stockbroker line is as follows: The line starts with the number of contacts (n), followed by n pairs of integers, one pair for each contact. Each pair lists first a number referring to the contact (e.g. a '1' means person number one in the set), followed by the time in minutes taken to pass a message to that person. There are no special punctuation symbols or spacing rules. 

    Each person is numbered 1 through to the number of stockbrokers. The time taken to pass the message on will be between 1 and 10 minutes (inclusive), and the number of contacts will range between 0 and one less than the number of stockbrokers. The number of stockbrokers will range from 1 to 100. The input is terminated by a set of stockbrokers containing 0 (zero) people. 

    Output

    For each set of data, your program must output a single line containing the person who results in the fastest message transmission, and how long before the last person will receive any given message after you give it to this person, measured in integer minutes. 
    It is possible that your program will receive a network of connections that excludes some persons, i.e. some people may be unreachable. If your program detects such a broken network, simply output the message "disjoint". Note that the time taken to pass the message from person A to person B is not necessarily the same as the time taken to pass it from B to A, if such transmission is possible at all.

    Sample Input

    3
    2 2 4 3 5
    2 1 2 3 6
    2 1 2 2 2
    5
    3 4 4 2 8 5 3
    1 5 8
    4 1 6 4 10 2 7 5 2
    0
    2 2 5 1 5
    0

    Sample Output

    3 2
    3 10

    Source

    英文真的很长很难懂,但算法是很简单的,就是一个floyd 3重循环
    主要意思就是几个炒股的要通风报信,求通风报信的最短时间(可同时通风报信给多人)
    第一行就是输入炒股的人的个数n
    接下来n行
    比如 第一行第一个数字是这个炒股的1号能通报给几个人 后面的数字是给第几号需要多少时间
    第二行就是炒股的2号 blabla以此类推
    注意这个传递方向是有向的...

    求从第几号炒股的开始传信号 所需的时间最少 求出这个最短时间
    强调一下信号能同时发出去哟,所以构建的邻接矩阵都不用怎么处理直接就能得出这个值

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int N=110;
    const int INF=0x3f3f3f3f;
    
    int map[N][N],n;
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d",&n) && n){
            int i,j,k;
            for(i=1;i<=n;i++)
                for(j=1;j<=n;j++)
                    map[i][j]=INF;
            int m,w;
            for(i=1;i<=n;i++){
                scanf("%d",&m);
                for(k=1;k<=m;k++){
                    scanf("%d%d",&j,&w);
                    map[i][j]=w;
                }
            }
    
            for(k=1;k<=n;k++)
                for(i=1;i<=n;i++)
                    for(j=1;j<=n;j++)
                        if(map[i][j]>map[i][k]+map[k][j])
                            map[i][j]=map[i][k]+map[k][j];
    
            int ans=INF,tmp;
            for(i=1;i<=n;i++){
                tmp=0;
                for(j=1;j<=n;j++)
                    if(i!=j && tmp<map[i][j])   //记录每行的最大值
                        tmp=map[i][j];
                if(ans>tmp){    //最大值中最小的
                    ans=tmp;
                    k=i;
                }
            }
            if(ans==INF)
                printf("disjoint\n");
            else
                printf("%d %d\n",k,ans);
        }
        return 0;
    }
  • 相关阅读:
    部署NetCore项目(本文介绍用用IIS部署)
    vs中添加MySql实体集流程
    一文搞定HashMap的实现原理
    二分查找
    hashcode返回值可能为负数
    哈希碰撞与生日攻击
    并发的第二天
    java并发编程-1
    排序的第一天
    并发的第一天
  • 原文地址:https://www.cnblogs.com/jackge/p/3016526.html
Copyright © 2020-2023  润新知