• HDU 1042 N!


    N!

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 40204    Accepted Submission(s): 11162

    Problem Description
    Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
     
    Input
    One N in one line, process to the end of file.
     
    Output
    For each N, output N! in one line.
     
    Sample Input
    1
    2
    3
     
    Sample Output
    1
    2
    6
     
    Author
    JGShining(极光炫影)
     
     
     
     
    import java.util.*;
    import java.math.*;
    
    public class Main{
        public static void main(String[] args){
            Scanner cin = new Scanner(System.in);
            BigInteger ans;
            int n;
            while(cin.hasNext()){
                n = cin.nextInt();
                ans = BigInteger.valueOf(1);
                for(int i=2; i<=n; i++)
                    ans = ans.multiply(BigInteger.valueOf(i));
                System.out.println(ans);
            }
        }
    }
  • 相关阅读:
    杂篇章
    敲代码中遇到的小问题
    数组的运用
    java中强大的免费的集成开发环境(IDE)eclipse的使用技巧及注意事项
    流程
    博客目录
    pgk
    gogs
    github相关
    axios记录
  • 原文地址:https://www.cnblogs.com/jackge/p/2990051.html
Copyright © 2020-2023  润新知