• HDU 1297 Children’s Queue


    Children’s Queue

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8194    Accepted Submission(s): 2603

    Problem Description
    There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
     
    Input
    There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
     
    Output
    For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
     
    Sample Input
    1
    2
    3
     
    Sample Output
    1
    2
    4
     
    Author
    SmallBeer (CML)
     
    Source
     
    Recommend
    lcy
     
     
     
     
    import java.util.*;
    import java.math.*;
    
    public class Main{
        public static void main(String[] args){
            Scanner cin = new Scanner(System.in);
            BigInteger []num = new BigInteger[1010];
            num[1] = BigInteger.valueOf(1);
            num[2] = BigInteger.valueOf(2);
            num[3] = BigInteger.valueOf(4);
            num[4] = BigInteger.valueOf(7);
            for(int i=5; i<1001; i++)
                num[i] = num[i-1].add(num[i-2].add(num[i-4]));
            int n;
            while(cin.hasNext()){
                n = cin.nextInt();
                System.out.println(num[n]);
            }
        }
    }
  • 相关阅读:
    在linux服务器上下载github上的源码
    docker
    使用 vue-cli 搭建项目
    用vue手脚架直接修改.vue文件会报错
    JavaScript ES6中export及export default的区别
    node.js npm install 模块 无反应
    node.js 初级配置
    node.js 配置首页打开页面
    nodejs取得当前执行路径
    初始化bootstrap-fileinput 组件
  • 原文地址:https://www.cnblogs.com/jackge/p/2990040.html
Copyright © 2020-2023  润新知