• HDU 1026 Ignatius and the Princess I


    Ignatius and the Princess I

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 8405    Accepted Submission(s): 2499

    Special Judge

    Problem Description
    The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:
    1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1). 2.The array is marked with some characters and numbers. We define them like this: . : The place where Ignatius can walk on. X : The place is a trap, Ignatius should not walk on it. n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.
    Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.
     
    Input
    The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.
     
    Output
    For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.
     
    Sample Input
    5 6
    .XX.1.
    ..X.2.
    2...X.
    ...XX.
    XXXXX.
    5 6
    .XX.1.
    ..X.2.
    2...X.
    ...XX.
    XXXXX1
    5 6
    .XX...
    ..XX1.
    2...X.
    ...XX.
    XXXXX.
     
    Sample Output
    It takes 13 seconds to reach the target position, let me show you the way.
    1s:(0,0)->(1,0)
    2s:(1,0)->(1,1)
    3s:(1,1)->(2,1)
    4s:(2,1)->(2,2)
    5s:(2,2)->(2,3)
    6s:(2,3)->(1,3)
    7s:(1,3)->(1,4)
    8s:FIGHT AT (1,4)
    9s:FIGHT AT (1,4)
    10s:(1,4)->(1,5)
    11s:(1,5)->(2,5)
    12s:(2,5)->(3,5)
    13s:(3,5)->(4,5)
    FINISH
    It takes 14 seconds to reach the target position, let me show you the way.
    1s:(0,0)->(1,0)
    2s:(1,0)->(1,1)
    3s:(1,1)->(2,1)
    4s:(2,1)->(2,2)
    5s:(2,2)->(2,3)
    6s:(2,3)->(1,3)
    7s:(1,3)->(1,4)
    8s:FIGHT AT (1,4)
    9s:FIGHT AT (1,4)
    10s:(1,4)->(1,5)
    11s:(1,5)->(2,5)
    12s:(2,5)->(3,5)
    13s:(3,5)->(4,5)
    14s:FIGHT AT (4,5)
    FINISH
    God please help our poor hero.
    FINISH
     
    Author
    Ignatius.L
     
     
     
    #include<iostream>
    #include<queue>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    const int maxn=120;
    
    int n,m;
    int visited[maxn][maxn],fight[maxn][maxn];
    
    struct node{
        int x,y;
        int time;
        bool operator < (const node &a) const{
            return a.time<time;
        }
    };
    
    struct node1{
        int nx,ny;
        char c;
    }map[maxn][maxn];
    
    int dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};
    
    int BFS(){
        priority_queue<node> myqueue;
        while(!myqueue.empty())
            myqueue.pop();
        node cur,next;
        cur.x=n-1;cur.y=m-1;
        char s=map[n-1][m-1].c;
        if(s>='1' && s<='9'){
            cur.time=s-'0';
            fight[n-1][m-1]=s-'0';
        }else
            cur.time=0;
        visited[n-1][m-1]=1;
        myqueue.push(cur);
        int x,y;
        while(!myqueue.empty()){
            cur=myqueue.top();
            myqueue.pop();
            if(cur.x==0 && cur.y==0)
                return cur.time;
            for(int i=0;i<4;i++){
                next.x=x=cur.x+dir[i][0];
                next.y=y=cur.y+dir[i][1];
                if(x>=0 && x<n && y>=0 && y<m && map[x][y].c!='X' && !visited[x][y]){
                    visited[x][y]=1;
                    s=map[x][y].c;
                    if(s>='1' && s<='9'){
                        next.time=cur.time+1+s-'0';
                        fight[x][y]=s-'0';
                    }else
                        next.time=cur.time+1;
                    map[x][y].nx=cur.x;
                    map[x][y].ny=cur.y;
                    myqueue.push(next);
                }
            }
        }
        return -1;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(scanf("%d%d",&n,&m)!=EOF){
            getchar();
            int i,j;
            for(i=0;i<n;i++){
                for(j=0;j<m;j++){
                    scanf("%c",&map[i][j].c);
                }
                getchar();
            }
            memset(visited,0,sizeof(visited));
            memset(fight,0,sizeof(fight));
            int ans=BFS();
            //printf("ans=%d\n",ans);
            if(ans==-1)
                printf("God please help our poor hero.\n");
            else{
                printf("It takes %d seconds to reach the target position, let me show you the way.\n",ans);
                int cnt=1,x=0,y=0;
                while(cnt<=ans){
                    int fx=map[x][y].nx,fy=map[x][y].ny;
                    printf("%ds:(%d,%d)->(%d,%d)\n",cnt++,x,y,fx,fy);
                    for(j=1;j<=fight[fx][fy];j++)
                    printf("%ds:FIGHT AT (%d,%d)\n",cnt++,fx,fy);
                    x=fx;y=fy;
                }
            }
            printf("FINISH\n");
        }
        return 0;
    }
  • 相关阅读:
    C# 调用AForge类库操作摄像头
    Composer简介及使用实例
    asp.net mvc 接入美圣短信 验证码发送
    敏捷模式下携程的接口自动化平台演变
    17个Python的牛逼骚操作,你都OK吗?
    如何打造一份优雅的简历?
    谈谈少儿编程
    打基础一定要吃透这12类 Python 内置函数
    求职日记丨秋招面试零失败,我拿下宝洁、华为、壳牌等offer
    我只想找个测试岗,你却百般刁难我!
  • 原文地址:https://www.cnblogs.com/jackge/p/2986230.html
Copyright © 2020-2023  润新知