• HDU 1503 Advanced Fruits


    Advanced Fruits

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 1083    Accepted Submission(s): 526

    Special Judge

    Problem Description
    The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.  A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 
    A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 
    Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 
     
    Input
    Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.
    Input is terminated by end of file. 
     
    Output
    For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
     
    Sample Input
    apple peach
    ananas banana
    pear peach
     
    Sample Output
    appleach
    bananas
    pearch
     
    Source
     
    Recommend
    linle
     
     
     
    解题思路:这道题就是给你两个单词,然后你要把两个单词拼接成一个新单词,使得新单词的子序列中包含两个单词,并且要使这个新单词最短。所以这道题就是求最长公共子序列,并且要记录下子序列的字母,以及他们在主串和副串中的原始位置,之后进行拼接输出。
     
    #include<stdio.h>
    #include<string.h>
    
    const int maxn=210;
    
    char str1[maxn],str2[maxn];
    int dp[maxn][maxn],len; //len指示ans的长度
    
    struct node{
        int i,j;    //i记录主串位置,j记录副串当前字符位置
        char ch;        //记录当前字符
    }ans[maxn];
    
    int max(int a,int b){
        return a>b?a:b;
    }
    
    void LCS(int m,int n){
        memset(dp,0,sizeof(dp));
        int i,j;
        for(i=1;i<=m;i++)
            for(j=1;j<=n;j++)
                if(str1[i]==str2[j])
                    dp[i][j]=dp[i-1][j-1]+1;
                else
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
        if(dp[m][n]==0){    //如果没有公共序列,直接输出 
            printf("%s%s",str1,str2);
        }else{
            i=m;j=n;
            len=0;
            while(i!=0 && j!=0){    //取出最长公共子序列的字母
                if((dp[i][j]==dp[i-1][j-1]+1) && str1[i]==str2[j]){
                    ans[len].i=i;
                    ans[len].j=j;
                    ans[len++].ch=str1[i];      //倒序保存最长公共子序列字母
                    i--;j--;
                }else if(dp[i-1][j]>dp[i][j-1])
                    i--;
                else
                    j--;
            }
        }
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int len1,len2,i,j,k;
        while(scanf("%s%s",str1+1,str2+1)!=EOF){
            len1=strlen(str1+1);
            len2=strlen(str2+1);
            LCS(len1,len2);
            i=j=1;
            for(k=len-1;k>=0;k--){
                while(i!=ans[k].i){
                    printf("%c",str1[i]);
                    i++;
                }
                while(j!=ans[k].j){
                    printf("%c",str2[j]);
                    j++;
                }
                printf("%c",ans[k].ch);
                i++;j++;
            }
            printf("%s%s\n",str1+1+ans[0].i,str2+1+ans[0].j);
        }
        return 0;
    }
  • 相关阅读:
    小程序自动更新版本
    js深浅拷贝理解
    小程序模仿toast效果
    小程序button默认border
    Java利用POI 读取Excel行列数,坑
    Nginx 极简入门教程
    七、SpringBoot整合持久化层,配置多数据源(SpringBoot系列)
    六、SpringBoot整合aop(SpringBoot系列)
    五、SpringBoot随系统启动任务的方式(SpringBoot系列)
    四、SpringBoot通过CORS解决跨域问题(SpringBoot系列)
  • 原文地址:https://www.cnblogs.com/jackge/p/2984662.html
Copyright © 2020-2023  润新知