• HDU 1501 Zipper


    Zipper

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4575    Accepted Submission(s): 1629

    Problem Description
    Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.
    For example, consider forming "tcraete" from "cat" and "tree":
    String A: cat String B: tree String C: tcraete
    As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":
    String A: cat String B: tree String C: catrtee
    Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".
     
    Input
    The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.
    For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.
     
    Output
    For each data set, print:
    Data set n: yes
    if the third string can be formed from the first two, or
    Data set n: no
    if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.
     
    Sample Input
    3
    cat tree tcraete
    cat tree catrtee
    cat tree cttaree
     
    Sample Output
    Data set 1: yes
    Data set 2: yes
    Data set 3: no
     
    Source
     
    Recommend
    linle
     
     
     
    #include<stdio.h>
    #include<string.h>
    
    const int maxn=220;
    
    char str1[maxn],str2[maxn],str3[2*maxn];
    int len1,len2,len3;
    int visited[maxn][maxn],flag;
    
    void DFS(int a,int b,int c){
        if(flag)
            return ;
        if(c==len3){
            flag=1;
            return ;
        }
        if(!visited[a][b]){
            visited[a][b]=1;
            if(str1[a]==str3[c])
                DFS(a+1,b,c+1);
            if(str2[b]==str3[c])
                DFS(a,b+1,c+1);
        }
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int n,cases=0;
        scanf("%d",&n);
        while(n--){
            scanf("%s%s%s",str1,str2,str3);
            len1=strlen(str1);
            len2=strlen(str2);
            len3=strlen(str3);
            printf("Data set %d: ",++cases);
            if(len1+len2!=len3){
                printf("no\n");
                continue;
            }
            memset(visited,0,sizeof(visited));
            flag=0;
            DFS(0,0,0);
            if(flag)
                printf("yes\n");
            else
                printf("no\n");
        }
        return 0;
    }
  • 相关阅读:
    校验身份证号、邮箱、手机号
    星级评分插件
    JS 实现轮播图
    js 禁止网页后退
    删除Redis缓存
    分析器错误,未能加载类型
    Vue 禁止按钮重复提交
    Vue 页面加载前显示{{代码}}的原因及解决办法 PC端
    设计模式之策略模式
    数据库索引知识到MySQL InnoDB
  • 原文地址:https://www.cnblogs.com/jackge/p/2984386.html
Copyright © 2020-2023  润新知