• POJ 2909 Goldbach's Conjecture


    Goldbach's Conjecture
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 9192   Accepted: 5357

    Description

    For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that

    n = p1 + p2

    This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

    A sequence of even numbers is given as input. There can be many such numbers. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

    Input

    An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 215. The end of the input is indicated by a number 0.

    Output

    Each output line should contain an integer number. No other characters should appear in the output.

    Sample Input

    6
    10
    12
    0

    Sample Output

    1
    2
    1

    Source

     
     
    #include<stdio.h>
    #include<string.h>
    
    const int maxn=100000;
    
    int prime[maxn+10];
    
    void getPrime(){
        memset(prime,1,sizeof(prime));
        prime[0]=prime[1]=0;
        for(int i=2;i*i<=maxn;i++)
            if(prime[i])
                for(int j=i*i;j<=maxn;j+=i)
                    prime[j]=0;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int n,cnt;
        getPrime();
        while(scanf("%d",&n) && n){
            cnt=0;
            for(int i=2;i<=n/2;i++)
                if(prime[i] && prime[n-i])
                    cnt++;
            printf("%d\n",cnt);
        }
        return 0;
    }
  • 相关阅读:
    python json模块出现Invalid control character这个异常的原因
    KMS服务,使用命令激活windows/office
    vscode Python文件头部信息
    MIMIC-III Clinical Database 翻译
    autohotkey 设置
    DeepLearning 写代码常用
    VScode 个人设置
    随机种子设置
    samba配置
    jieba 分词不显示日志
  • 原文地址:https://www.cnblogs.com/jackge/p/2977726.html
Copyright © 2020-2023  润新知