• POJ 1269 Intersecting Lines


    Intersecting Lines
     
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 7897   Accepted: 3613

    Description

    We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.  Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000. 

    Input

    The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

    Output

    There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

    Sample Input

    5
    0 0 4 4 0 4 4 0
    5 0 7 6 1 0 2 3
    5 0 7 6 3 -6 4 -3
    2 0 2 27 1 5 18 5
    0 3 4 0 1 2 2 5
    

    Sample Output

    INTERSECTING LINES OUTPUT
    POINT 2.00 2.00
    NONE
    LINE
    POINT 2.00 5.00
    POINT 1.07 2.20
    END OF OUTPUT
    

    Source

     
     
    #include<iostream>
    #include<cstdio>
    
    using namespace std;
    
    #define eps 1e-8
    
    struct point{
        double x,y;
    }p1,p2,p3,p4;
    
    double Abs(double x){
        return x>0?x:-x;
    }
    
    void Solve(point p1,point p2,point p3,point p4){
        double t1=(p2.x-p1.x)*(p3.y-p4.y)-(p2.y-p1.y)*(p3.x-p4.x);
        double t2=(p3.x-p1.x)*(p3.y-p4.y)-(p3.y-p1.y)*(p3.x-p4.x);
        if(Abs(t1)<eps){
            if(Abs(t2)<eps)
                printf("LINE\n");
            else
                printf("NONE\n");
        }else{
            printf("POINT %.2f %.2f\n",p1.x+(p2.x-p1.x)*(t2/t1),p1.y+(p2.y-p1.y)*(t2/t1));
            //注意此处不能用%lf,而用%f
        }
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int n;
        scanf("%d",&n);
        printf("INTERSECTING LINES OUTPUT\n");
        while(n--){
            scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&p1.x,&p1.y,&p2.x,&p2.y,&p3.x,&p3.y,&p4.x,&p4.y);
            Solve(p1,p2,p3,p4);
        }
        printf("END OF OUTPUT\n");
        return 0;
    }
  • 相关阅读:
    Centos7 下安装python3及卸载
    centos python3 的 卸载 删除
    Centos7安装python3和pip3(一)
    python升级带来的yum异常(解决错误File "/usr/bin/yum", line 30 except KeyboardInterrupt, e:)
    python 错误信息是:sudo :apt-get:command not found
    优化页面访问速度(四) ——前端优化
    优化页面访问速度(三) ——服务端优化
    优化页面访问速度(二) ——数据库优化
    优化页面访问速度(一)——综述
    Redis专题——Redis管理工具
  • 原文地址:https://www.cnblogs.com/jackge/p/2964595.html
Copyright © 2020-2023  润新知