• HDU 2795 Billboard


    Billboard

    Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 5951    Accepted Submission(s): 2707


    Problem Description
    At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

    On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

    Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

    When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

    If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

    Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
     
    Input
    There are multiple cases (no more than 40 cases).

    The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

    Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
     
    Output
    For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
     
    Sample Input
    3 5 5 2 4 3 3 3
     
    Sample Output
    1 2 1 3 -1
     
    Author
    hhanger@zju
     
    Source
     
    Recommend
    lcy
     
     
     
     
    #include<stdio.h>
    
    #define lson l,mid,rt<<1
    #define rson mid+1,r,rt<<1|1
    
    const int maxn=200010;
    int h,w,n;
    int Max[maxn<<2];
    
    int max(int a,int b){
        return a>b?a:b;
    }
    
    void PushUp(int rt){
        Max[rt]=max(Max[rt<<1],Max[rt<<1|1]);
    }
    
    void build(int l,int r,int rt){
        Max[rt]=w;
        if(l==r)
            return ;
        int mid=(l+r)>>1;
        build(lson);
        build(rson);
        PushUp(rt);
    }
    
    int query(int x,int l,int r,int rt){
        if(l==r){
            Max[rt]-=x;
            return l;
        }
        int mid=(l+r)>>1;
        int ans=(Max[rt<<1]>=x)?query(x,lson):query(x,rson);
        PushUp(rt);
        return ans;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        while(~scanf("%d%d%d",&h,&w,&n)){
            if(h>n)
                h=n;
            build(1,h,1);
            int x;
            while(n--){
                scanf("%d",&x);
                if(Max[1]<x)
                    puts("-1");
                else
                    printf("%d\n",query(x,1,h,1));
            }
        }
        return 0;
    }
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    
    #define L(rt) (rt<<1)
    #define R(rt) (rt<<1|1)
    
    const int N=200010;
    
    int h,w;
    
    struct node{
        int l,r;
        int w;  //w 保存该区间内能贴的最大宽度的宣传单
    }tree[N*3];
    
    void build(int l,int r,int rt){
        tree[rt].l=l;
        tree[rt].r=r;
        tree[rt].w=w;
        if(l==r)
            return ;
        int mid=(l+r)>>1;
        build(l,mid,L(rt));
        build(mid+1,r,R(rt));
    }
    
    int query(int len,int rt){
        int res;
        if(tree[rt].l==tree[rt].r){ //找到叶结点(每个叶结点代表一行)
            tree[rt].w-=len;
            return tree[rt].l;
        }
        if(tree[L(rt)].w>=len)
            res=query(len,L(rt));
        else
            res=query(len,R(rt));
        tree[rt].w=max(tree[L(rt)].w,tree[R(rt)].w);    //递归回来的时候 修改父亲结点的信息
        return res;
    }
    
    int main(){
    
        //freopen("input.txt","r",stdin);
    
        int len,n;
        while(~scanf("%d%d%d",&h,&w,&n)){
            if(h>n)  //最多也只有n行而已
                h=n;
            build(1,h,1);
            while(n--){
                scanf("%d",&len);
                if(len>tree[1].w)    //如果len>node[1].w 那说明白贴不进去了
                    printf("-1\n");
                else
                    printf("%d\n",query(len,1));
            }
        }
        return 0;
    }
  • 相关阅读:
    文件处理
    字符编码的了解以及简单的文件处理
    python list去重加set排序
    数据的类型以及内置方法
    Python 入门 Day5
    Python 入门 Day3
    Python的入门
    计算机硬件
    【0903 | Day 29】反射和内置方法
    【0902 | Day 28】绑定方法和非绑定方法
  • 原文地址:https://www.cnblogs.com/jackge/p/2952580.html
Copyright © 2020-2023  润新知