• HDU 1009 FatMouse' Trade


    FatMouse' Trade

    http://acm.hdu.edu.cn/showproblem.php?pid=1009

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 28122    Accepted Submission(s): 9028

    Problem Description
    FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean. The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
     
    Input
    The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.
     
    Output
    For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
     
    Sample Input
     
    5 3
    7 2
    4 3
    5 2
    20 3
    25 18
    24 15
    15 10
    -1 -1
     
    Sample Output
     
    13.333
    31.500
     
    Author
    CHEN, Yue
     
    Source
     
    Recommend
    JGShining
     
     
    sort版本
     
    #include<stdio.h>
    #include<stdlib.h>
    #include<iostream>
    #include<algorithm>
    
    using namespace std;
    
    struct node{
        int j,f;
        double r;
    }food[1005];
    
    int cmp(node a,node b){
        return a.r>b.r;
    }
    
    int main(){
        int m,n;
        while(scanf("%d%d",&m,&n)){
            if(m==-1 && n==-1)
                break;
            int i;
            for(i=0;i<n;i++){
                scanf("%d%d",&food[i].j,&food[i].f);
                food[i].r=(double)food[i].j/food[i].f;
            }
            //qsort(food,n,sizeof(node),cmp);
            sort(food,food+n,cmp);
            double ans=0;
            for(i=0;i<n;i++)
                if(m>=food[i].f){
                    m-=food[i].f;
                    ans+=food[i].j;
                }else{
                    ans+=(food[i].j*1.0/food[i].f)*m;
                    break;
                }
            printf("%.3lf\n",ans);
        }
        return 0;
    }

    qsort版本

    #include<stdio.h>
    #include<stdlib.h>
    #include<iostream>
    #include<algorithm>
    
    using namespace std;
    
    struct node{
        int j,f;
        double r;
    }food[1005];
    
    int cmp(const void *a,const void *b){
        node c=*(node *)a;
        node d=*(node *)b;
        if(c.r>d.r)
            return -1;
        else
            return 1;
    }
    
    int main(){
        int m,n;
        while(scanf("%d%d",&m,&n)){
            if(m==-1 && n==-1)
                break;
            int i;
            for(i=0;i<n;i++){
                scanf("%d%d",&food[i].j,&food[i].f);
                food[i].r=(double)food[i].j/food[i].f;
            }
            qsort(food,n,sizeof(food[0]),cmp);
            //sort(food,food+n,cmp);
            double ans=0;
            for(i=0;i<n;i++)
                if(m>=food[i].f){
                    m-=food[i].f;
                    ans+=food[i].j;
                }else{
                    ans+=(food[i].j*1.0/food[i].f)*m;
                    break;
                }
            printf("%.3lf\n",ans);
        }
        return 0;
    }
  • 相关阅读:
    网上邻居无法打开的问题 客户端无法连接打印机问题
    今天一天下午到晚上都在研究如何刷手机,要是被领导知道我帮同学在刷手机系统,非开除我不可。还是贴出来,以后少走弯路吧
    “屏幕保护程序”没有出现“在恢复时使用密码保护”的解决方法
    NOD 32客户端安装时出现的问题
    [模板]二叉树的前、中、后序遍历
    [算法]浅谈求n范围以内的质数(素数)
    [模板]二叉搜索树
    [OI]Noip 2018 题解&总结(普及)
    Centos7.2安装git(源码安装)
    Centos7.2安装maven
  • 原文地址:https://www.cnblogs.com/jackge/p/2838453.html
Copyright © 2020-2023  润新知