• Spell checker


    Description

    You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms. 
    If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations: 
    ?deleting of one letter from the word; 
    ?replacing of one letter in the word with an arbitrary letter; 
    ?inserting of one arbitrary letter into the word. 
    Your task is to write the program that will find all possible replacements from the dictionary for every given word. 

    Input

    The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary. 
    The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked. 
    All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most. 

    Output

    Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

    Sample Input

    i
    is
    has
    have
    be
    my
    more
    contest
    me
    too
    if
    award
    #
    me
    aware
    m
    contest
    hav
    oo
    or
    i
    fi
    mre
    #

    Sample Output

    me is correct
    aware: award
    m: i my me
    contest is correct
    hav: has have
    oo: too
    or:
    i is correct
    fi: i
    mre: more me

    【题意】给出字典中一些单词,再给出要检验的单词,问字典中是否存在该单词或者经过替换,删除、插入某个字母与字典中某词一样;

    【思路】直接stecmp检验是否在字典中有相同的单词,然后根据len1,len2的大小进行讨论。

    相同时,是否能进行替换,只需比较当前单词是否与字典中的单词存在一个字母的差异;

    相差为1时,是否进行插入、删除,只需使较长的那个单词删去一个字母,比较是否相同

    #include<iostream>
    #include<stdio.h>
    #include<string.h>
    using namespace std;
    const int N=10010;
    char dic[N][55];
    char word[55][55];
    int i1,j1;
    bool check(char *a)
    {
        for(int i=0; i<=i1; i++)
        {
            if(!strcmp(a,dic[i])) return true;
        }
        return false;
    }
    bool del(char *a,char *b)
    {
        int len=strlen(a);
        int i=0,j=0,cnt=0;
        while(i<len)
        {
            if(a[i]!=b[j])
            {
                i++;
                cnt++;
                if(cnt>1) return false;
            }
            else {i++;j++;}
        }
        return true;
    }
    bool instead(char *a,char *b)
    {
        int cnt=0;
        int len=strlen(a);
        for(int i=0;i<len;i++)
        {
            if(a[i]!=b[i]) cnt++;
            if(cnt>1) return false;
        }
        return true;
    }
    int main()
    {
        i1=0;
        j1=0;
        while(cin>>dic[i1]&&dic[i1][0]!='#') i1++;
        while(cin>>word[j1]&&word[j1][0]!='#') j1++;
        i1--;
        j1--;
        for(int i=0; i<=j1; i++)
        {
            if(check(word[i]))
    
            {
                cout<<word[i]<<" is correct"<<endl;
                continue;
            }
            cout<<word[i]<<": ";
            for(int j=0; j<=i1; j++)
            {
                int len1=strlen(dic[j]);
                int len2=strlen(word[i]);
                if(len1==len2)
                {
                    if(instead(word[i],dic[j]))
                        cout<<dic[j]<<" ";
                }
                else if(len1+1==len2)
                {
                    if(del(word[i],dic[j]))
                        cout<<dic[j]<<" ";
                }
                else if(len1==len2+1)
                {
                    if(del(dic[j],word[i]))
                        cout<<dic[j]<<" ";
                }
            }
            cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Spring学习笔记之四----基于Annotation的Spring AOP编程
    Spring学习笔记之三----基于Annotation的Spring IOC配置
    Spring学习笔记之一----基于XML的Spring IOC配置
    Spring学习笔记之二----基于XML的Spring AOP配置
    Swift语言之类型方法
    Swift语言之命令模式(Command Pattern)实现
    用Swift语言做App开发之单元测试
    Spring Batch学习笔记三:JobRepository
    Spring Batch学习笔记二
    初探Spring Batch
  • 原文地址:https://www.cnblogs.com/iwantstrong/p/5824795.html
Copyright © 2020-2023  润新知