• A Walk Through the Forest_spfa&&dfs


    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 11   Accepted Submission(s) : 8

    Font: Times New Roman | Verdana | Georgia

    Font Size: ← →

    Problem Description

    Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable. 
    The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take. 

    Input

    Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections. 

    Output

    For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647

    Sample Input

    5 6
    1 3 2
    1 4 2
    3 4 3
    1 5 12
    4 2 34
    5 2 24
    7 8
    1 3 1
    1 4 1
    3 7 1
    7 4 1
    7 5 1
    6 7 1
    5 2 1
    6 2 1
    0
    

    Sample Output

    2
    4

    假设 A 和 B 是相连的,当前在 A 处,如果 A 到终点的距离大于 B 到终点的距离,则可以从 A 通往 B 处,问满足这种的条件的路径条数。

    分析:1、spfa以终点开始求到各点的最短距离;
            2、直接DFS记忆化搜索。
    #include<iostream>
    #include<stdio.h>
    #include<queue>
    #include<string.h>
    using namespace std;
    const int N=1005;
    const int inf=0x7777777;
    int mp[N][N];
    int n,m;
    int vis[N];
    int num[N],dis[N];
    void init()
    {
        memset(num,0,sizeof(num));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                mp[i][j]=inf;
            }
            mp[i][i]=0;
        }
    
    }
    void spfa(int s)
    {
        queue<int>qu;
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++) dis[i]=inf;
        dis[s]=0,vis[s]=1;
        qu.push(s);
        while(!qu.empty())
        {
            int t=qu.front();
            qu.pop();
            vis[t]=0;
            for(int i=1;i<=n;i++)
            {
                if(dis[i]>dis[t]+mp[t][i])
                {
                    dis[i]=dis[t]+mp[t][i];
                    if(!vis[i])
                    {
                        vis[i]=1;
                        qu.push(i);
                    }
                }
            }
        }
    }
    int dfs(int s)
    {
        if(num[s]) return num[s];
        if(s==2) return 1;
        int sum=num[s];
        for(int i=1;i<=n;i++)
        {
            if(mp[s][i]<inf&&dis[s]>dis[i])
            {
                if(num[i]) sum=sum+num[i];
                else sum+=dfs(i);
            }
        }
        num[s]=sum;
        return num[s];
    }
    int main()
    {
        while(cin>>n,n)
        {
            cin>>m;
            init();
            for(int i=1;i<=m;i++)
            {
                int a,b,c;
                cin>>a>>b>>c;
                mp[a][b]=mp[b][a]=c;
            }
            spfa(2);
            cout<<dfs(1)<<endl;
        }
    }
  • 相关阅读:
    设备像素比devicePixelRatio简单介绍
    详解事件代理委托
    原生dom事件注册和移除事件的封装
    idataway_前端代码规范
    170307、1分钟实现“延迟消息”功能
    170306、wamp中的Apache开启gzip压缩提高网站的响应速度
    170303、PHP微信公众平台开发接口 SDK完整版
    170302、 Apache 使用localhost(127.0.0.1)可以访问,使用本机局域网IP(192.168.2.*)不能访问
    170301、使用Spring AOP实现MySQL数据库读写分离案例分析
    170228、Linux操作系统安装ELK stack日志管理系统--(1)Logstash和Filebeat的安装与使用
  • 原文地址:https://www.cnblogs.com/iwantstrong/p/5767964.html
Copyright © 2020-2023  润新知